Step out should show the completion value

RESOLVED DUPLICATE of bug 923975

Status

enhancement
P2
normal
RESOLVED DUPLICATE of bug 923975
Last year
2 months ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

(Blocks 2 bugs)

unspecified
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

https://bugzilla.mozilla.org/show_bug.cgi?id=923975 is changing step out so that instead of pausing in the pop handler it pauses in the parent's onStep. This change means that we need to update how we show completion values for step out.

> function a() {
>   return 2;
> }
>
> b(a()) // <-- show a's completion value here


I believe the patch can look something like this [1], but my biggest question is how we should show the return value. Should it be `<return> 2` like we typically show it or should we include the name of the frame we're leaving from.

[1] https://github.com/jasonLaster/gecko-dev/commit/54a3ace77ac07fd42fb8035eb796ccc620dbbe73
Assignee: nobody → jlaster
Blocks: js-devtools
Priority: -- → P3
Blocks: dbg-stepping
Priority: P3 → P2
Blocks: dbg-control
No longer blocks: dbg-stepping
Duplicate of this bug: 1326837
Flags: qe-verify+
Blocks: dbg-68
Assignee: jlaster → nobody
Whiteboard: [debugger-mvp]
Assignee: nobody → jlaster
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923975
Whiteboard: [debugger-mvp]
You need to log in before you can comment on or make changes to this bug.