Findbar next/previous buttons look very bad on dark developer edition theme

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
2 years ago
5 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Unspecified
Windows 7
regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20161119030204 (2016-11-19)
STR_1:
0. Open customize mode, enable developer edition theme. Open devtools, set dark theme, close devtools.
1. Open url   data:,asdf
2. Open findbar, type "zxcv" in findbar

AR:  Next/previous buttons are completely gray, up/down arrows aren't visible
ER:  Up and down arrows should be noticeable in findbar buttons

This is regression from bug 935521. Regression range:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0cb0af1888e39f777862c2c24d84832b6622d40f&tochange=89101092aea13babe5a9a9e4750b89758425f1e2
(Reporter)

Updated

2 years ago
No longer blocks: 1277113
(Reporter)

Updated

2 years ago
Component: Untriaged → Theme

Updated

2 years ago
Blocks: 1331679
Created attachment 8831209 [details]
Nightly.png

Works for me, see screenshot
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Re-opened, apparently this happens on Win7
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Flags: qe-verify?
OS: Unspecified → Windows 7
Priority: -- → P3
Is there someone who can test this on Windows 7 ? Bug 1418605 might have fixed this.
Flags: needinfo?(jgriffiths)
I have no idea, redirecting to Harald. Probably needs a QA flag.
Flags: needinfo?(jgriffiths) → needinfo?(hkirschner)
Without a screenshot of the issue, it's kind of hard to know whether this was fixed.
I tested on Windows 10 with DevEdition (60), and couldn't see any problem there. I'll post a screenshot of that.
I also tested on Windows 7 with Beta (60), and couldn't see any problem there either.

Note that the STRs have changed since the bug was filed, since the dark them is now decoupled from the DevTools dark theme:

0. Open customize mode, choose dark theme.
1. Open url   data:,asdf
2. Open findbar, type "zxcv" in findbar
Flags: needinfo?(hkirschner)
Created attachment 8970441 [details]
windows7-FF60.png

Here's a screenshot on Windows 7.
Thanks Patrick! The screenshot looks correct to me, so I'm going to close this.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.