Closed Bug 1327385 Opened 3 years ago Closed 3 years ago

Cut-Copy-Paste are NOW broken, Episode 2 - Paste is disabled in <input readonly>

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1317322

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression, Whiteboard: Cut, copy, paste buttons intentionally broken in bug 1159490 by Ehsan Akhgari)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url   data:text/html,<input onpaste="alert()" readonly value="do you see it? your bug">
2. Right-click in the <input>


STR_2:
0. Move Cut-Copy-Paste toolbarbutton to toolbar
1. Open url   data:text/html,<input onpaste="alert()" readonly value="do you see it? your bug">
2. Click in the <input>


AR:  Cut, Copy are enabled, Paste is disabled
ER:  Either X or Y
 X) Everything should work just like before regression 1159490:  Step 2 - All items should be disabled
 Y) Step 4 - all items should be enabled, i.e. Ehsan Akhgari should at least make his terrible design
    of Cut,Copy,Paste (that is illogical and doesn't make sense for people who use the browser) work
    as HE expects. I.e. should just finish the job. Or don't even start. I hope this concept is clear.
Component: Untriaged → DOM: Events
Product: Firefox → Core
No longer blocks: 1277113
Hi Ehsan, is this on your radar? It seems a regression from a previous bug 1159490.
Flags: needinfo?(ehsan)
So, Arni's rude comments aside, it should probably enable "paste" - as you can "cmd-v" into it, and the event picks it up.
This is a duplicate of bug 1317322.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1317322
You need to log in before you can comment on or make changes to this bug.