After regression in bug 1267617 I can no longer work around your bug 1231025 with CSS -moz-box-ordinal-group

RESOLVED WONTFIX

Status

()

Firefox
Site Identity and Permission Panels
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>>>   My Info:   Win7_64, Nightly 50, 32bit, ID 20160715063552 (2016-07-15)
"-moz-box-ordinal-group" CSS property is used to change sequence of items in -moz-box.
Using that CSS property, I was able to fix the terrible bug 1231025 (showing how much Firefox 
developers are focused on useless improvements rather than real bugs and don't have any well-defined
plan on development (if they had a plan, they whouldn't regress bug 1231025 further and further, would
they?)). Now it's not possible, due to poor implementation of identity block (result of completely
random changes including bug 1267617 not requested/approved by any user)

AR:  Bug 1231025 is present, unlike on Firefox 49
ER:  There should be a way to work around bug 1231025 with CSS while FX team is breaking other things

Notes:
1) Looking at what has been broken in bug 1267617, I see that there's no way to fix this using CSS.
2) There're really obvious solutions: (I only mention them, because everybody would pretend that
   they don't understand what I meant. It only happens when people refuse to think on the topic)
 2.1) Display http/https icon instead of terrible (i) button (you'll need it anyway to fix
      bug 1231025), and place notification anchors right after identity block,
      i.e. in the next sibling, not inside identity block
 2.2) Just place notification anchors right after identity block, i.e. in the next sibling, not inside
      identity block. Thus, sequence of displayed icons will be:    (i) - https - notification anchors
      Note that (2.2) partially fixes another type of twitching in identity block - when button is
      added below mouse pointer 0.1s before click. See bug 1238637, bug 1251864, bug 1258687 comment 5
 2.3) Move https button to the  END  of notification anchors and place notification anchors right
      after identity block, i.e. in the next sibling, not inside identity block.
     (2.3) visually looks just like current design.
 2.4) Move https button to the START of notification anchors and place notification anchors right
      after identity block, i.e. in the next sibling, not inside identity block.
     (2.4) visually looks just like (2.2), and also fixes twitching "button appears 0.1s before click"
 2.5) Actually fix bug 1231025
     (I don't even hope, because for past 2 years FX team was breaking UI, saying it's for good)

This is regression from bug 1267617. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=cc1d6ac8152de5394ca090ff24aa89c590ef87a4&tochange=3705eb1dc2cce4582cc3f95af52aeec700801fae@ Johann Hofmann [:johannh]:
It seems that this is a regresion caused by your change. Please have a look.
(Reporter)

Updated

a year ago
No longer blocks: 1277113
(Reporter)

Updated

a year ago
Component: Untriaged → Activity Streams: General
(Reporter)

Updated

a year ago
Component: Activity Streams: General → General
Component: General → Site Identity and Permission Panels
Yeah, this is a wontfix.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.