Closed Bug 1328049 Opened 4 years ago Closed 4 years ago

Plugin overlays are not displayed if plugin element is not fully visible

Categories

(Core :: Plug-ins, defect)

defect
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
0. Set Flash to "Ask to activate" or intall an obsolete version of Flash
1. Open the following URL (watch out, you'll run into bug 1258742):
> data:text/html,<body style="margin:0px;"><object data="https://bug1148978.bmoattachments.org/attachment.cgi?id=8675621" style="height:100%25;width:100%25;"></object><div style="position:fixed; bottom:0px;left:0px;right:0px; background:yellowgreen;">Yep. Just another perfectly shaped gray rectangle designed by Dolske & co.

STR_2:
0. Set Flash to "Ask to activate" or intall an obsolete version of Flash
1. Open Options -> privacy, set "Nightly will" to "Use custom settings for history",
   set "Accept third-party cookies" to "Never"
2. Open  http://dagobah.net/flash/lolicatgirls.swf

AR:  Gray box instead of Flash because of tiny bar at the bottom of the page
ER:  Some text or notification explaining why on earth Firefox created that gray rectangle

It was regressed in 2 steps.
STR_1 is regression from bug 976769. Regression range:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=529b86b92b1d&tochange=21740ba59e60

STR_2 is regression from bug 979318. Regression range:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f28005b84ed0&tochange=668f29cd71b3
No longer blocks: 1277113
Component: Untriaged → Plug-ins
Product: Firefox → Core
This is by design. If we detect that the plugin element is overlayed, we intentionally do not show the inline UI because the user likely cannot interact with it and it is more confusing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
FWIW, the notification bar should display in this case. Is the notification bar present?
Flags: needinfo?(arni2033)
(In reply to Benjamin Smedberg [:bsmedberg] from comment #1)
> This is by design. If we detect that the plugin element is overlayed, we intentionally do not show
> the inline UI because the user likely cannot interact with it and it is more confusing.
Please confirm that:
1) Flash opened on the whole content area should be hidden, because of small bar overlays 5% of the
   Flash object.
2) Please also confirm that in that case user can interact with it and it's not confusing.
3) Flash clipped by the same bar isn't hidden if it's also clipped by the edge of content area ([1])
4) Flash clipped by the same 5% by the edge of content area isn't hidden ([2])

(1),(2) prove that your UI hides plugin in more cases than it should. (3),(4) prove that your UI doesn't hide plugins in some cases when it should.
I often report illogical(=broken) things in FF. In this bug I want the resolution to mean that FF developers intentionally implemented all those inconsistencies, so asking you to confirm (1),(2),(3),(4) (i.e. that UI is broken) and that you don't want to fix it, i.e. provide good UX.

> [1] data:text/html,<body style="margin:0px;margin-bottom:-10px"><object data="https://bug1148978.bmoattachments.org/attachment.cgi?id=8675621" style="height:100%25;width:100%25;"></object><div style="position:fixed; bottom:0px;left:0px;right:0px; background:yellowgreen;">Yep. Just another perfectly shaped gray rectangle designed by Dolske & co.
> [2] data:text/html,<body style="margin:0px;margin-bottom:-30px"><object data="https://bug1148978.bmoattachments.org/attachment.cgi?id=8675621" style="height:100%25;width:100%25;"></object>


(In reply to Benjamin Smedberg [:bsmedberg] from comment #2)
> FWIW, the notification bar should display in this case. Is the notification bar present?
I filed separate bugs for the notification bar.
Flags: needinfo?(arni2033) → needinfo?(benjamin)
Usually plugins are hidden because of small "close" button that takes ~5% of plugin object's surface.
Therefore this bug asks for good UI and should be rather resolved "Wontfix" than "Worksforme".
> 1) Flash opened on the whole content area should be hidden, because of small
> bar overlays 5% of the
>    Flash object.

Correct.

> 2) Please also confirm that in that case user can interact with it and it's
> not confusing.

We don't know which parts the user can interact with or not. The entire box is no longer a reliable click target, and so we avoid asking users to try and sometimes fail.

> 3) Flash clipped by the same bar isn't hidden if it's also clipped by the
> edge of content area ([1])

If the plugin can be scrolled into view, then it should not be considered "hidden". If it is positioned outside the scrollable area then it should. This is admittedly hard because "scrollable" isn't entirely statically determined.

> 4) Flash clipped by the same 5% by the edge of content area isn't hidden
> ([2])

Given the restrictions of #3, correct.
Flags: needinfo?(benjamin)
(In reply to Benjamin Smedberg [:bsmedberg] from comment #5)
> > 3) Flash clipped by the same bar isn't hidden if it's also clipped by the
> > edge of content area ([1])
> 
> If the plugin can be scrolled into view, then it should not be considered
> "hidden". If it is positioned outside the scrollable area then it should.
> This is admittedly hard because "scrollable" isn't entirely statically determined.

In url [1] Flash can't be scrolled into view, therefore the logic doesn't apply.
UI doesn't hide the plugin when it should do so. I'll take this as confirmation

> > 4) Flash clipped by the same 5% by the edge of content area isn't hidden ([2])
> 
> Given the restrictions of #3, correct.

I gave you the wrong testcases then. Urls [3] and [4] contain Flash that couldn't be scrolled into
view. (remark about url [3] - currently it can be scrolled into view, because of bug 1272084).
Overall, I take (1),(2),(3),(4) as confirmation that you (team) intentionally implemented a bad UI w/o even trying to handle cases when a small percentage of plugin is overlapped. Thanks.

> [3] data:text/html,<body style="margin:0px;margin-bottom:-30px;overflow:hidden"><object data="https://bug1148978.bmoattachments.org/attachment.cgi?id=8675621" style="height:100%25;width:100%25;"></object>
> [4] data:text/html,<body style=""><object data="https://bug1148978.bmoattachments.org/attachment.cgi?id=8675621" style="width:100%25;position:fixed;bottom:-330px;top:0px;height:auto;margin:0px;"></object>
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → WONTFIX
You need to log in before you can comment on or make changes to this bug.