Add a test for 'shape-outside: border-box' combined with negative margins

RESOLVED FIXED in Firefox 61

Status

()

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: TYLin, Assigned: bradwerth)

Tracking

(Blocks 1 bug)

unspecified
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Quote from bug 1311244 comment 15, "It would also be good to have a test for this (margin-box clipping) for 'shape-outside: border-box' combined with negative margins."
I believe I've confirmed this doesn't work correctly, yet.
Assignee: nobody → bwerth
(In reply to Brad Werth [:bradwerth] from comment #1)
> I believe I've confirmed this doesn't work correctly, yet.

Whoops, now that I understand the spec statement "When a shape is used to define a float area, the shape is clipped to the float’s margin box.", then we do handle this correctly. I'll add a test that demonstrates this.
Attachment #8965166 - Flags: review?(dholbert)
Comment on attachment 8965166 [details]
Bug 1328236 Part 1: Add a web-platform test that shows shape-outside: border-box float areas are correctly clipped to margin rects.

https://reviewboard.mozilla.org/r/233850/#review239840
Attachment #8965166 - Flags: review?(dholbert) → review+
Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/548d76b29604
Add a web-platform test that shows shape-outside: border-box float areas are correctly clipped to margin rects. r=dholbert
Odd. The new test is designed to render the same as the existing, passing test /css-shapes/shape-outside/shape-box/shape-outside-box-007.html. I notice that the 007 test is NOT run in the failing TVw test on Windows platforms. So I'm going to duplicate that test and add it as a 010 test and see if it also fails on these platforms. It's the same test contents -- it should pass.
(In reply to Brad Werth [:bradwerth] from comment #14)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=34ab8b7b26fd4ead85b1a9cc8e5a6f84349f2ab6

Alright. This try result demonstrates that both the new tests 009 and 010 cause the test-verify-wpt-e10s job to fail on Windows platforms, EVEN THOUGH 010 is a clone of the existing 007 test. They fail in the same way, which is good because they are designed to render the same image.

The next step is to address this as a test automation issue. Once that are resolved, I can retest and hopefully land the new test.
Flags: needinfo?(bwerth)
What is the proper way to add a new web-platform test so it will not cause failures in the test-verify-wpt-e10s job? Part 1 of my patch added a new test that failed mysteriously and Part 2 copied an old, working test that failed in the same way. The test logs show that the test-verify-wpt-e10s job is not attempting to run any of the other tests in the same directory as the new tests. Do I need to specially annotate my new test to keep it out of this job?
Flags: needinfo?(gbrown)
(In reply to Dorel Luca [:dluca] from comment #9)
> Backed out changeset 548d76b29604 (bug 1328236) for TV failures on
> /css-shapes/shape-outside/shape-box/shape-outside-box-009.html
> 
> Log:
> https://treeherder.mozilla.org/logviewer.
> html#?job_id=172184843&repo=autoland&lineNumber=909
> 
> Backout:
> https://hg.mozilla.org/integration/autoland/rev/
> 446ec771003d64a088f0955b2e7ff5a28912d451
> 
> Push with failures:
> https://treeherder.mozilla.org/#/
> jobs?repo=autoland&revision=548d76b29604ca72e6dd68ba5544f56229e03e08


I believe TVw is Tier-2 and as such it's not appropriate to back out for failures in this job.
Flags: needinfo?(sheriffs)
Discussed on irc - glad to help. afaik, there is no way to skip a wpt test only in TVw. 

More info at https://developer.mozilla.org/en-US/docs/Mozilla/QA/Test_Verification, if you are curious!
Flags: needinfo?(gbrown)
Attachment #8965513 - Attachment is obsolete: true
This push is attempting to exercise all the wpt tests on the troubled TVw platforms. If the regular wpt test jobs look good and the push only has TVw failures, then I'll try another landing.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f9171fea82843d2a4e72a5ffe913638892f0ff83
The try run looks good so I'll attempt another landing. I assume that any failures in TVw will not block landing.
Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b5bc270f3795
Part 1: Add a web-platform test that shows shape-outside: border-box float areas are correctly clipped to margin rects. r=dholbert
Would you mind verifying that some wpt test job in your Try run does indeed mention the new test's name? (to be sure it's actually being run)
Flags: needinfo?(bwerth)
(In reply to Daniel Holbert [:dholbert] (away 4/24 - 5/11) from comment #23)
> Would you mind verifying that some wpt test job in your Try run does indeed
> mention the new test's name? (to be sure it's actually being run)

https://treeherder.mozilla.org/logviewer.html#?job_id=172336747&repo=try&lineNumber=10191
Flags: needinfo?(bwerth)
https://hg.mozilla.org/mozilla-central/rev/b5bc270f3795
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Created web-platform-tests PR https://github.com/w3c/web-platform-tests/pull/10368 for changes under testing/web-platform/tests
Depends on: 1452308
You need to log in before you can comment on or make changes to this bug.