[WebExtensions] Firefox customization API request

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
2 years ago
9 months ago

People

(Reporter: aris-addons, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161222080852

Steps to reproduce:

https://webextensions-experiments.readthedocs.io/en/latest/ tells developers requesting new APIs for WebExtensions is a thing, so here is my request.

The new API should be able to target any DOM item (button, toolbar, tab, menus, popups, scrollbars, textboxes, windows, content etc.) and allow it to be changeable via css (size, [bg]image, icon, background, color, shape etc.) and movable/changeable via JavaScript (take item from position A on toolbar A, insert it into position B on toolbar B).

This is not a simple request of a "light" theming API where one can change the background colors of toolbars or font colors, but a request for being able to modify browsers UI the way it is possible with XUL items at the moment.

Something like that should have been the top priority when designing WebExtensions started. It is obvious add-ons developers do not want to lose any UI changing power after XUL/XPCOM support removal.
Sorry, but this is a non-starter. The Firefox UI is going to undergo massive changes, and any add-on that relied on an API like this would not survive them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
There is a dynamic theme API being worked on (bug 1306671) which will help with at least some of the requests from comment 0.

I agree with Kris though that the goal is to not have such low-level access to the browser DOM, since extensions and themes won't be able to keep up, and the status quo holds back any serious UI work.
See Also: → webext-themes
Comment hidden (advocacy)
So basically in simple, Mozilla want to kill the most powerful weapon Firefox has now - the configurability, customization and possibility to change anything to look how users and extensions developers want.
It's very sad to hear this, especially when this change won't bring Firefox any more user base, it unfortunately probably be otherwise.
Comment hidden (advocacy)
Comment hidden (advocacy)

Comment 7

2 years ago
(In reply to Tim Nguyen :ntim from comment #6)
> Developer Edition/Nightly should have those capabilities if needed, the user
> base there is technical enough to handle those kind of add-ons.
 
Yeah, it's just that α) API gonna be unstable, and β) hardly anybody would rewrite an addon, targeting exclusively the nightly builds, perhaps except of firefox devs.

> Keeping those legacy add-ons means taking no direction at all and not being
> able to innovate on the product.

"Those legacy addons" is the only reason I am — and probably, quite big number of peoples — still using the browser. See: every time I want to see youtube, or video, or something, I launch Chromium anyway, because firefox is α) laggy, and β) in 2017 still have problems with video acceleration.

But I am using firefox specifically for browsing at work and home only because of pentadactyl, which is one of those "legacy addons", as you called them. You drop "legacy addons" without a hope to get rewritten — you drop a big technical auditory, being the target of pentadactyl/vimperator/etc. Unless you're going to embed pentadactyl into the browser as a feature (which I dunno why you didn't, it'd be a killer-feature for devs), those peoples just go away to Chrome/Chromium. And, oh, wait, aren't technical peoples the ones being asked by "non-technical" ones "what a browser should I use"…?

Comment 8

2 years ago
(In reply to Hi-Angel from comment #7)
> (In reply to Tim Nguyen :ntim from comment #6)
> > Developer Edition/Nightly should have those capabilities if needed, the user
> > base there is technical enough to handle those kind of add-ons.
>  
> Yeah, it's just that α) API gonna be unstable, and β) hardly anybody would
> rewrite an addon, targeting exclusively the nightly builds, perhaps except
> of firefox devs.
It's simply too much support needed to get these very low-level APIs available on the release channels. They break Firefox and most people don't know what's going on.

> But I am using firefox specifically for browsing at work and home only
> because of pentadactyl, which is one of those "legacy addons", as you called
> them. You drop "legacy addons" without a hope to get rewritten — you drop a
> big technical auditory, being the target of pentadactyl/vimperator/etc.
> Unless you're going to embed pentadactyl into the browser as a feature
> (which I dunno why you didn't, it'd be a killer-feature for devs), those
> peoples just go away to Chrome/Chromium. And, oh, wait, aren't technical
> peoples the ones being asked by "non-technical" ones "what a browser should
> I use"…?

Who says pentadactyl/vimperator won't be supported by the new APIs? They don't need any very low-level API, at least not what's described here.

pentadactyl/vimperator just add an extra toolbar and interact with the content. WebExtensions already provide the "interact with the content" part, and the toolbar API will be added in bug 1215064.

This proves that this bug is too broad in its current form that people no longer know what they're talking about.

Comment 9

2 years ago
(In reply to Tim Nguyen :ntim from comment #8)
> Who says pentadactyl/vimperator won't be supported by the new APIs? They don't
> need any very low-level API, at least not what's described here.
> 
> pentadactyl/vimperator just add an extra toolbar and interact with the content.
> WebExtensions already provide the "interact with the content" part, and the
> toolbar API will be added in bug 1215064.

Sounds nice, but just to be sure: does functionality of WebExtensions allow: 

1. Disable whole line, which usually contains URL bar, and icons of installed extensions?
2. Make a single-line label to show a text (e.g. URL and some stats).
3. Make a textedit (e.g. upon pressing "Shift+o" in pentadactyl, the mentioned label transforms to a textedit, allowing to modify the text)
4. Make a multi-line label (e.g. upon pressing "Shift+o" in pentadactyl to edit a URL, pentadactyl raises a widget with suggestions).

Besides, it would be great if the label (well, I don't know what that widget is actually called) allowed colors and pictures — e.g. suggestions in pentadactyl ATM are of a form "site_picture | url_in_bold | page_name_in_green".

Comment 10

2 years ago
…well, by "WebExtensions" I rather meant an API, including proposed ones too, like the toolbar API you mentioned.

Comment 11

2 years ago
(In reply to Hi-Angel from comment #9)
The first request is bug 1332447.
The second one is the toolbar API.
The third one is already possible.
The last one is also the toolbar API.

Kris (who just wontfixed this bug) may be better at answering those questions than I am since he created pentadactyl.

You shouldn't worry about this bug being closed: the title itself is too broad (customization has a lot of meanings, which a lot of them are covered by other bugs, or by existing APIs) and the description is a basic request for the old system back which basically doesn't help with anything...
Comment hidden (advocacy)
Comment hidden (advocacy)

Comment 14

2 years ago
(In reply to Kris Maglione [:kmag] from comment #1)
> Sorry, but this is a non-starter. The Firefox UI is going to undergo massive
> changes, and any add-on that relied on an API like this would not survive
> them.

Just a clarification question so there is no confusion for the addon developers. Thats a 

"no never"

or

"not now, but AFTER the Firefox UI has had the massive changes"
Flags: needinfo?(kmaglione+bmo)

Comment 15

2 years ago
(In reply to kalviskajaks from comment #14)
> "not now, but AFTER the Firefox UI has had the massive changes"

At the some point in the future, ideas and opinions might change and we might start to see changes in direction, sure. But for the forseeable, I agree with Kris and Rob that this is not going to happen.

Comment 16

2 years ago
Hi everyone,

I'm an avid and loyal FF user (not a dev, though I am a web dev and thus, have a technical bent of mind).

I've read through ALL the comments (visible and hidden) on this bug because I needed to know how massively disruptive the change to added functionality from FF addons would be to my experience.

From what I can see, not much.

FF has a very loyal fan following. It is already a niche browser. I applaud Mozilla in taking on the challenge of refactoring the giant gargantuan beast that is FF and modularising it so that addons (soon to be WebExtensions) will be decoupled from the core.

As a Drupal developer, I can see how this would raise concerns in many but am writing to try and assuage the concerns of others who may stumble upon this thread. Drupal has seen massive changes in the last several years and has moved further and further into de-coupling and modularisation of components. By doing so, it has allowed for greater and greater freedom and better and better standards in its contributor community.

My thought is, let's let the FF core developers do what they need to do to bring FF up to par and even beyond its competitors. If the infrastructure supporting addons is causing too much of a lag in its current form, now is the time for this un-productive coupling to be resolved. I am willing to wait to see how things move forward.

One other bit of experience that makes me feel hopeful that the capabilities of addons/WExes will not be throttled is the fact that we have seen major addons bounce back to life after other major changes. When signing became a thing, I saw all of my favourite (and "can't live without") extensions make their way forward. This was not the first time that there was a span of time when some of my addons stopped working. I've grown accustomed to an FF update "breaking" my addons, re-installing an old version of FF for a few months and then, voila! a few months later, when attempting a fresh and latest-version install of FF, finding that ALL of my addons were available for usage again.

We as a community of consumers (developers, technically adept users and non-technical users alike) need to just take a breath and let Mozilla make the changes that they NEED to. We need to have faith in their judgment. I'm SURE that this decision was NOT a flippant and spur of the moment one.

Thank you Mozilla devs for all your time and hard work. I hope to see FF come out of this upheaval stronger and better than ever and to see its market share grow to meet and surpass Chrome!
Comment hidden (advocacy)
Comment hidden (abuse-reviewed)
Comment hidden (advocacy)
Terrell Kelley, vague comments on this bug aren't going to do anything to help.  Have you reported (ideally by opening bugs) the specific problems you have encountered?
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (off-topic)
Restrict Comments: true

Updated

11 months ago
Product: Toolkit → WebExtensions
Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.