The default bug view has changed. See this FAQ.
Bug 1306671 (webext-themes)

Prototype new Theme API

RESOLVED FIXED

Status

()

Toolkit
WebExtensions: General
P3
normal
RESOLVED FIXED
6 months ago
25 days ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

(Depends on: 7 bugs, Blocks: 1 bug, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged, URL)

This is a preliminary/research attempt at a new Theme API implemented as part of WebExtensions. This bug will track the work necessary for a prototype-implementation of this API.

Work will be committed to the Cedar repo, https://treeherder.mozilla.org/#/jobs?repo=cedar
(Assignee)

Updated

6 months ago
Depends on: 1306676
(Assignee)

Updated

6 months ago

Updated

6 months ago
Priority: -- → P3
Whiteboard: triaged
(Assignee)

Updated

6 months ago
Depends on: 1307202
Depends on: 1309908
Depends on: 1310144
Depends on: 1311352

Updated

5 months ago
Depends on: 1311722
Depends on: 1313325

Updated

5 months ago
Assignee: nobody → jaws

Updated

5 months ago
Depends on: 1271481

Updated

5 months ago
Alias: webext-themes

Updated

5 months ago
Depends on: 1314145
See Also: → bug 1314091
(Assignee)

Updated

5 months ago
Depends on: 1315255
Depends on: 1316603
(Assignee)

Updated

4 months ago
Depends on: 1319821
(Assignee)

Updated

4 months ago
Depends on: 1319836
(Assignee)

Updated

4 months ago
Depends on: 1319840
(Assignee)

Updated

4 months ago
Depends on: 1319873
(Assignee)

Updated

4 months ago
Depends on: 1319893

Comment 1

4 months ago
Hello Jared Wein, please set "Blocks" field to 1320336

Updated

4 months ago
Blocks: 1320336

Comment 2

4 months ago
Ah, I'm sorry, I could set the "Depends on" field myself, I didn't know.

Done.

Updated

4 months ago
Duplicate of this bug: 1320585

Updated

4 months ago
Depends on: 1320585

Updated

4 months ago
Blocks: 1215059

Updated

4 months ago
No longer blocks: 1320336
(Assignee)

Updated

4 months ago
Depends on: 1320781
(Assignee)

Updated

4 months ago
Depends on: 1320788
(Assignee)

Updated

4 months ago
Depends on: 1320789

Comment 4

4 months ago
Sorry if I'm noising up the bug, and if this is made obvious somewhere (I missed it), but a user left this comment on reddit:

> It's the only browser that is good for visually impaired people as you can change the size of the font for menus and favorites. If it goes away then I would be stuck with using a magnifying glass with chrome or IE/edge.
https://www.reddit.com/r/firefox/comments/5g25fy/mozilla_is_doing_well_financially_2015/dapr8xb/

And I was wondering if this is accounted for in the current planned feature set.
(In reply to Caspy7 from comment #4)
> Sorry if I'm noising up the bug, and if this is made obvious somewhere (I
> missed it), but a user left this comment on reddit:
> 
> > It's the only browser that is good for visually impaired people as you can change the size of the font for menus and favorites. If it goes away then I would be stuck with using a magnifying glass with chrome or IE/edge.
> https://www.reddit.com/r/firefox/comments/5g25fy/
> mozilla_is_doing_well_financially_2015/dapr8xb/
> 
> And I was wondering if this is accounted for in the current planned feature
> set.

Yes, we are discussing how we could implement zooming. Whether this is defined by the theme or in the preferences of the browser is still undecided.
See Also: → bug 1328244
This prototype phase has concluded. Implementation of the API is tracked in bug 1330328.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Summary: Implement new Theme API → Prototype new Theme API
(Assignee)

Updated

2 months ago
No longer depends on: 1319821

Updated

25 days ago
No longer depends on: 1320585
You need to log in before you can comment on or make changes to this bug.