SM-Trunk: Selection of text no longer visible

RESOLVED WONTFIX

Status

()

Core
Widget: Gtk
RESOLVED WONTFIX
11 months ago
11 months ago

People

(Reporter: Hartmut Figge, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

53 Branch
Unspecified
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
In today's build of SM-Trunk Linux x86_64 selection of text is no longer visible. In browser or MailNews. On Modern or Default.

Regression window:
Last good: 2017-01-02 17:43:00 PST   c-c:bbb39b5643e8 m-c:c91249f41e37
First bad: 2017-01-03 15:29:00 PST   c-c:614e97c63b00 m-c:cad2ea346d06
(Reporter)

Comment 1

11 months ago
As a check I have built a TB-Trunk Linux x86_64. Same issue. So the matter should probably be transferred from SeaMonkey to, hm, Core. I will leave that for you. ;)
(Reporter)

Updated

11 months ago
Summary: SM-Trunk: Selection of text not loger visible → SM-Trunk: Selection of text no longer visible
(Reporter)

Comment 2

11 months ago
A User with a normal Daily didn't see the issue, so the regression window can be reduced to

Last good: 2017-01-03 03:02:11 PST
(Reporter)

Comment 3

11 months ago
The regression is caused by Bug 1320860. Verified by back out of 'bug 1320860 adjust textarea style contexts for GTK 3.20 theming ABI changes'

Comment 4

11 months ago
Because of the referenced Bug 1320860 LINUX for now.
OS: Unspecified → Linux
Version: Trunk → SeaMonkey 2.50 Branch

Comment 5

11 months ago
Due to Comment 3
See Also: → bug 1320860

Comment 6

11 months ago
What is the GTK version in use?

(In reply to Hartmut Figge from comment #0)
> On Modern or Default.

Are these GTK themes?  If so, where can I obtain these?

If not, what is the GTK theme?
(Reporter)

Comment 7

11 months ago
I am using Gentoo mostly stable with gtk+ 3.20.9 with the theme Raleigh. The latter being one of the few which has arrows on top and bottom of the scrollbars under gtk3.

I will check other themes if they are affected by this bug.
(Reporter)

Comment 8

11 months ago
(In reply to Hartmut Figge from comment #7)

> I will check other themes if they are affected by this bug.

Only testing Modern this time. With a build without the previously mentioned backout. Ambiance is not affected but doesn't have the arrows on the scrollbars. I will refer to this in short as arrows.

Clearlooks-Phenix is not affected and has the arrows. But trying to send a comment using this theme I recognized that it was not possible. No 'Save Changes' was visible. :)

No desktop environment here. No Gnome, KDE etc., only a window manager, IceWM. Seems I'm stuck with Raleigh and the backout.

Comment 9

11 months ago
gtk3-widget-factory demonstrates the same bug, indicating that this is a bug in gtk+, which does not yet have a workaround in Raleigh (in the same package).

Easiest workaround for now would be to use gtk+-3.18.9.

Another option may be to add some entries to ~/.config/gtk-3.0/gtk.css to turn on scrollbar arrows.  Comparing files from themes with and without arrows should identify what is needed.  The arrows may not be well styled if the theme is not designed with arrows in mind, but that can also be adjusted in ~/.config/gtk-3.0/gtk.css.
Blocks: 1264079, 1320860
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Component: General → Widget: Gtk
Product: SeaMonkey → Core
Resolution: --- → WONTFIX
See Also: bug 1320860
Version: SeaMonkey 2.50 Branch → 53 Branch
You need to log in before you can comment on or make changes to this bug.