Closed Bug 1320860 Opened 3 years ago Closed 3 years ago

adjust textarea style contexts for GTK 3.20 theming ABI changes

Categories

(Core :: Widget: Gtk, defect, P2)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: karlt, Assigned: karlt)

References

(Blocks 1 open bug)

Details

(Whiteboard: tpi:+)

Attachments

(4 files)

No description provided.
Comment on attachment 8815162 [details]
bug 1320860 introduce MOZ_GTK_TEXT_VIEW_TEXT and move MOZ_GTK_RESIZER to WidgetStyleCache +263117

https://reviewboard.mozilla.org/r/96192/#review96464

Looks okay.
Attachment #8815162 - Flags: review?(stransky) → review+
Pushed by ktomlinson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72eb22d75bca
adjust textarea style contexts for GTK 3.20 theming ABI changes r=stransky+263117
Priority: -- → P2
Whiteboard: tpi:+
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/a6aabcb07a6e
adjust textarea style contexts for GTK 3.20 theming ABI changes r=stransky+263117
https://hg.mozilla.org/mozilla-central/rev/a6aabcb07a6e
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Depends on: 1322120
Depends on: 1322413
Depends on: 1322290
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla53 → ---
Comment on attachment 8815162 [details]
bug 1320860 introduce MOZ_GTK_TEXT_VIEW_TEXT and move MOZ_GTK_RESIZER to WidgetStyleCache +263117

This is what landed in a6aabcb07a6e plus the fix for bug 1322120 minus the changes in behavior for 3.20 that caused bug 1324262.
This is mostly already reviewed, but not exactly, so requesting another quick look over, please?

Bug 1324262 and the changes in the node for 3.20 are in the subsequent commits.
Attachment #8815162 - Flags: review+ → review?(stransky)
this backout caused a perf regression (removing a win from the original landing):
== Change summary for alert #4664 (as of December 29 2016 07:50 UTC) ==

Regressions:

  3%  tsvgr_opacity summary linux64 pgo e10s     337.66 -> 347.12
  2%  tsvgr_opacity summary linux64 pgo          371.06 -> 380.01

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=4664

looking forward to these relanding
Comment on attachment 8822595 [details]
bug 1320860 consider textview root node background in addition to text node for -moz-field

https://reviewboard.mozilla.org/r/101458/#review102138

::: widget/gtk/nsLookAndFeel.cpp:66
(Diff revision 1)
>  #endif
>  }
>  
>  #if MOZ_WIDGET_GTK != 2
> +// Modifies color aDest as if color aSource was painted over aDest
> +static void

Please provide comment that we apply CAIRO_OPERATOR_OVER here.
Attachment #8822595 - Flags: review?(stransky) → review+
Comment on attachment 8822596 [details]
bug 1320860 consider textview root node background in addition to text node for -moz-appearance:textfield-multiline

https://reviewboard.mozilla.org/r/101460/#review102140
Attachment #8822596 - Flags: review?(stransky) → review+
Comment on attachment 8822597 [details]
bug 1320860 adjust textarea style contexts for GTK 3.20 theming ABI changes +263117

https://reviewboard.mozilla.org/r/101462/#review102144
Attachment #8822597 - Flags: review?(stransky) → review+
Comment on attachment 8815162 [details]
bug 1320860 introduce MOZ_GTK_TEXT_VIEW_TEXT and move MOZ_GTK_RESIZER to WidgetStyleCache +263117

https://reviewboard.mozilla.org/r/96192/#review102146
Attachment #8815162 - Flags: review?(stransky) → review+
(In reply to Joel Maher ( :jmaher) from comment #14)
> this backout caused a perf regression (removing a win from the original
> landing):
> == Change summary for alert #4664 (as of December 29 2016 07:50 UTC) ==
> 
> Regressions:
> 
>   3%  tsvgr_opacity summary linux64 pgo e10s     337.66 -> 347.12
>   2%  tsvgr_opacity summary linux64 pgo          371.06 -> 380.01

Interesting, thanks.

I expected changes for this bug to have a performance impact only on -moz-appearance:textfield-multiline and/or -moz-appearance:resizer.  I don't see use of these in chrome.  I wonder whether the test uses textareas somewhere.

The code affected does determine colors that are used in chrome, but these are calculated only once, and so performance differences are not expected to be measurable.
Pushed by ktomlinson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4591009826a2
introduce MOZ_GTK_TEXT_VIEW_TEXT and move MOZ_GTK_RESIZER to WidgetStyleCache r=stransky+263117+263117
https://hg.mozilla.org/integration/autoland/rev/c47ada33b755
consider textview root node background in addition to text node for -moz-field r=stransky+263117
https://hg.mozilla.org/integration/autoland/rev/8409c3695877
consider textview root node background in addition to text node for -moz-appearance:textfield-multiline r=stransky+263117
https://hg.mozilla.org/integration/autoland/rev/e71b038223a4
adjust textarea style contexts for GTK 3.20 theming ABI changes r=stransky+263117+263117
Depends on: 1328352
OS Unspecified? This seems to be a Linux issue
Linux for now.
OS: Unspecified → Linux
See Also: → 1328510
Depends on: 1328510
See Also: 1328510
Depends on: 1364079
You need to log in before you can comment on or make changes to this bug.