Closed Bug 1329154 Opened 3 years ago Closed 7 months ago

Custom tabs: If user has ad blocker add-on installed, enable ad blocking in custom tabs

Categories

(Firefox for Android :: Custom Tabs, defect, P2)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- verified

People

(Reporter: jcheng, Assigned: esawin)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

As a user, if I have adblocker add-on on my full Firefox for Android, I also want my custom tabs to have the same functionality
This should already be the case out of the box (but needs testing / QA). If add-ons use APIs to modify the browser UI (e.g. add an icon to the URL bar) then this does not work in the custom tab activity so far.
Per comment1, and the Phase#1 MVP consideration, will not be considered in the phase1  scope. 
Thank you !
Priority: -- → P3
As comment #4 says, this should just work currently, but I'm not sure if GeckoView-based custom tabs will break it or not. Dylan?
Flags: needinfo?(droeh)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #3)
> As comment #4 says, this should just work currently, but I'm not sure if
> GeckoView-based custom tabs will break it or not. Dylan?

I'll have to test to be certain, but I do kind of suspect GV-based custom tabs will break this.
Flags: needinfo?(droeh)
Priority: P3 → P1
snorp, can we retest and see if this is still an issue?
Flags: needinfo?(snorp)
Assignee: nobody → esawin
Flags: needinfo?(snorp)
FYI, this was not an issue last time I tested (maybe a month ago); I doubt anything needs to be done here.
Testing with uBlock Origin 1.14.4, ad-blocking does not work in GeckoView-based custom tabs (bug 1356346).
Priority: P1 → P2
The regression range [1] includes bug 1356346, which means we've broken support for this particular extension (uBlock Origin) when moving to GeckoView-based custom tabs.
There are two things to consider, our move to GeckoView and the add-on's move to a WebExtensions implementation.

The XUL/XPCOM-based add-on version depends heavily on the window.BrowserApp interface and its tab-based interactions.
At the same time, our implementation of WebExtensions does also depend on BrowserApp for tab management in [2].

The immediate way to enable support for WebExtensions in GeckoView is to add a stub implementation of BrowserApp which treats the view as a (single) tab.

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=24012764504b8cf504354c1135c5b01a01fbc346&tochange=90436b206b3d754e482c8d6160274e62a87d5e8d
[2] https://searchfox.org/mozilla-central/source/mobile/android/components/extensions/ext-utils.js
Attachment #8907242 - Flags: review?(snorp)
Comment on attachment 8907242 [details] [diff] [review]
0001-Bug-1329154-1.0-Add-GeckoView-BrowserApp-stub-to-sup.patch

Review of attachment 8907242 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, this could make devtools work too, I think?
Attachment #8907242 - Flags: review?(snorp) → review+
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b382ec54d164
[1.0] Add GeckoView BrowserApp stub to support WebExtensions. r=snorp
Depends on: 1399518
https://hg.mozilla.org/mozilla-central/rev/b382ec54d164
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
There's definitely been a regression in the 58 builds with this! uBlock Origin does not seem to be working properly (or at all?) in custom tabs in the latest Nightlies.
(In reply to KotW from comment #13)
> There's definitely been a regression in the 58 builds with this! uBlock
> Origin does not seem to be working properly (or at all?) in custom tabs in
> the latest Nightlies.

It works for me on Nightly 2017-10-12.
Can you please file a bug with steps, if you can reproduce and CC/NI me?
Verified as fixed in build 57 Beta 7;
Device: Samsung Galaxy Tab 3 (Android 7.0).
Not sure this is a right place for my bug so excuse me if I'm wrong.
uBlock also doesn't work with fullscreen (no browser UI) sites opened from homescreen shortcuts.
Device: Google Pixel XL (Android P)
Firefox: 61 stable.

Hi,

I managed to reproduce the issue

Environment:
Device: Google Pixel C, Android (8.0.0)
Build: Firefox Beta 67.0b18

This replicated with "Ublock" add-on instead of "Adblocker".

Regards,
Diana Rus

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Component: General → Custom Tabs
OS: Unspecified → Android
Hardware: Unspecified → ARM
Status: REOPENED → RESOLVED
Closed: 2 years ago7 months ago
Resolution: --- → FIXED
See Also: → 1549683
You need to log in before you can comment on or make changes to this bug.