Need IMAP OPEN Shared Folders icons for all the OPENED Shared folders including alphabetical, default and special shared folders

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: huang, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Used 03-22-05-trunk build

Need OPEN Shared Folders icons for those Shared folders which including 
subfolders.
(Should apply to all the shared alphabetical, default and special folders for 
both Classic & Modern Themes)

-------------------------------------------------------------------------------
Refer to bug 28756, we already had IMAP CLOSED shared folders icons for 1st 
level alphabetical shared folder.

Based on the UI Spec as following:
http://www.mozilla.org/mailnews/specs/folder/#Sharing

We still need IMAP Opened Shared Folders icons for those Shared folders which 
including subfolders.
(Should apply to all the shared alphabetical, default and special folders for 
both Classic & Modern Themes)
------------------------------------------------------------------------------

The only exception are: 
Messaging, AOL, UW and SIMS Inboxes 
(Since users cannot create subfolders for those IMAP Servers Inboxes.....)

Ccing Jennifer.
(Reporter)

Comment 1

17 years ago
Nominating nsbeta1 for MachV IMAP shared folders UI.
Keywords: nsbeta1
QA Contact: olgam → huang

Comment 2

17 years ago
modern skin doesn't have open folder icons, so I don't see how this could apply
to the modern skin. I would recommend not fixing this anyway - the extra style
rules and rdf reflection would be a pain and have a negative performance impact.
(Reporter)

Updated

17 years ago
Blocks: 112096
(Reporter)

Comment 3

17 years ago
From UI Spec, I did see "open shared folder icons" for modern skin. 
But David is right, we don't even have open folder(alphabetical folders)icons 
for modern skin on current trunk build.....performance reasons?
(Reporter)

Comment 4

17 years ago
Classic skin doesn't have open folder(alphabetical folders)icons either, not 
only modern.....

Comment 5

17 years ago
different icons for open folders seem of very limited value - you can tell the
folder is expanded because of the twisty and the list of sub-folders underneath it.

Comment 6

17 years ago
Marlon, are "open" versions of folders something that Modern or Classic is 
currently using?

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: huang → message-display
Target Milestone: mozilla1.2alpha → ---

Comment 7

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 8

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.