Expose e10s multiprocess configuration to end-users in about:preferences

RESOLVED DUPLICATE of bug 1354473

Status

()

Firefox
Preferences
P1
normal
RESOLVED DUPLICATE of bug 1354473
6 months ago
a month ago

People

(Reporter: canuckistani, Assigned: phlsa)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 55
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User Story

E10S Multi UI Preferences

As a user curious about the new Electrolysis multi-process feature, I would like to know more about how Firefox is configured for my system as well as potentially be able to adjust the e10s multi settings in about:prefs.

* As a user on a system with less than 4GB of RAM, I am curious to know how much RAM Firefox is actually using.
  * I would like to know how much RAM is being used by Firefox as well as by web content and addons
  * I would like to be able to access RAM usage of web pages per page
* If I see that Firefox is using too much RAM by default, I would like to be able to change the setting to use as little RAM as possible.
  * As a Photoshop user I would like to minimize the ram usage of all other applications, including Firefox
  * As a user on a system with less than 2GB of RAM, I would like to limit Firefox to the least RAM usage possible.
* As a user on a workstation that has 32GB of RAM and > 4 cores /  > 2 cpus, I would like to use as much RAM as possible in order to improve performance and responsiveness.
* As a user who is curious about Firefox’s support for multiple processes, I would like check that Firefox has chosen a multiprocess configuration that is appropriate for my system.
We'd like to explore how to expose multi-process configuration options to end-users.
(Reporter)

Updated

6 months ago
User Story: (updated)
Hey Phillip - what's the status of this? Last I heard I had the impression that TDC was going to fold the work into the other prefs stuff, but given that multi may ship in 54 we may want to ship something very simple as a companion feature.
Flags: needinfo?(philipp)
Yes, TDC is working on it (NI Tina).
They are about to do some user testing right now, but I am not fully in the loop here.

We should look at how far it has gotten. I think the basic concept[1] we looked at when I was in Toronto is still a candidate, but I assume that there's something better by now :)

[1] https://mozilla.invisionapp.com/share/BWADX1YR4#/217291974_Artboard_1
Flags: needinfo?(philipp) → needinfo?(thsieh)
We have some ongoing implementations for the reorganization of about:prefs, so we try to help performance options to find a right category in the new organization by conducting a user test. I hope that we can ship the test this week so that we can have the result as soon as possible. 

As far as I know, about:prefs currently is short of dev resources so it's hard to have new changes. For the schedule of about:prefs, I think Cindy can share more details about it :)
Flags: needinfo?(thsieh) → needinfo?(chsiang)

Comment 4

3 months ago
We've been using student resources (from Michigan State U) and can keep them till the end of April. We have a status check meeting with them tomorrow and should have a better idea on the progress. We need to scope in the part that's needed for Photon release or else there will be no resources after April.
Flags: needinfo?(chsiang)
Blocks: 1352831

Comment 5

3 months ago
Got @fischer to work on this. Targeting 55.
(In reply to chsiang from comment #5)
> Got @fischer to work on this. Targeting 55.
Hum, I thought Evan is going to help us out with mentorship from Fischer, given that he is wrapping up storage mgmt?

Anyway, I will have the sort this out.

Comment 8

3 months ago
It's your call Tim!

Comment 9

3 months ago
hi all,

per discussion with Evan, now we have following 2 dependencies:
1. find out if page fetching API exists? Evan is on this one.
2. Come out final UX spec including review by USA side. Tina is on this one, she will keep us posted.

once these 2 above were clarified, an ETA date for fixing this bug can be defined with accuracy.
for now, we are still targeting to fix it by 2nd nightly 55.

hope this answers some of your questions.

thank you very much

Comment 10

3 months ago
(In reply to Francis Lee [:frlee] from comment #9)
> hi all,
> 
> per discussion with Evan, now we have following 2 dependencies:
> 1. find out if page fetching API exists? Evan is on this one.
Found, looks like `network.prefetch-next` is what we want.
Thanks for Henry's help.

> Link prefetching is a browser mechanism, which utilizes browser idle time to download or prefetch documents that the user might visit in the near future. [1]

[1]: https://developer.mozilla.org/en-US/docs/Web/HTTP/Link_prefetching_FAQ

Comment 11

3 months ago
> 2. Come out final UX spec including review by USA side. Tina is on this one,
> she will keep us posted.

Just a reminder for us. We will also send our UX spec to Preference code module owners or reviewers (Jared and Gijs) and get the feedback from them.

Comment 12

3 months ago
The prefs to control process count is dom.ipc.processCount.* [1].
The types definition is at [2].
[1] http://searchfox.org/mozilla-central/rev/fcd9f1480d65f1a5df2acda97eb07a7e133f6ed4/modules/libpref/init/all.js#3082
[2] http://searchfox.org/mozilla-central/rev/fcd9f1480d65f1a5df2acda97eb07a7e133f6ed4/dom/ipc/ContentParent.h#40

Updated

3 months ago
Blocks: 1354473

Comment 13

3 months ago
I filed a meta bug (Bug 1354473) for our Performance settings section. We could discuss the UX spec for all performance settings we would like to add into Preferences and engineering items of other performance settings (except e10s multiprocess configuration) there.

Updated

2 months ago
Whiteboard: [photon-preference]
No longer blocks: 1352831
This bug represents UX while other bugs under bug 1354473 (or bug 1354473 itself) represents engineering.
status-firefox53: affected → ---
Whiteboard: [photon-preference] → [photon-preference][ux]

Updated

2 months ago
Target Milestone: --- → Firefox 55
Is the spec considered complete? Let's close this one out if it does.

(maybe link to it here or upload a final PDF for record keeping purpose, thanks)
Flags: needinfo?(thsieh)
Flags: needinfo?(philipp)
Hey Tim,
I'm OK with closing it :)
You'll see the spec in Bug 1354473.
Flags: needinfo?(thsieh)
Flags: needinfo?(philipp)

Updated

2 months ago
QA Contact: hani.yacoub

Updated

2 months ago
Flags: qe-verify-
QA Contact: hani.yacoub

Comment 17

2 months ago
close it as comment 16.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Priority: -- → P1
Resolution: --- → DUPLICATE
Duplicate of bug: 1354473

Updated

a month ago
Whiteboard: [photon-preference][ux]
You need to log in before you can comment on or make changes to this bug.