Intermittent devtools/client/debugger/test/mochitest/browser_dbg_sources-cache.js | A promise chain failed to handle a rejection: - [object Object]

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Debugger
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53 fixed, firefox54 fixed)

Details

(Whiteboard: [stockwell fixed])

Alexandre, do you have cycles to look into this new failure?
Flags: needinfo?(poirot.alex)
This test also had bug 1328192 filed against it recently, so that might be related.

Comment 3

a year ago
21 failures in 563 pushes (0.037 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 16
* try: 2
* mozilla-inbound: 2
* mozilla-central: 1

Platform breakdown:
* linux64: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1329427&startday=2017-01-02&endday=2017-01-08&tree=all

Comment 4

a year ago
40 failures in 128 pushes (0.313 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* autoland: 21
* mozilla-inbound: 14
* try: 2
* mozilla-central: 2
* graphics: 1

Platform breakdown:
* linux64: 40

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1329427&startday=2017-01-09&endday=2017-01-09&tree=all
I'm not able to reproduce it locally. That doesn't help.

I see two exceptions:
task 2017-01-07T00:43:15.424118Z] 00:43:15     INFO - console.error:
[task 2017-01-07T00:43:15.432470Z] 00:43:15     INFO -   Message: Error: Connection closed, pending request to server1.conn0.child1/performanceActor22, type connect failed

Which sounds like a cross test mixup. Given the stacks, it seems to break the test and introduce this second exception:

[task 2017-01-07T00:43:15.588618Z] 00:43:15     INFO - Full message: TypeError: editor is null
[task 2017-01-07T00:43:15.589450Z] 00:43:15     INFO - Full stack: waitForEditorEvents@chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/head.js:396:3

It looks like the connection opened for this test is closed while the test starts.
I'm wondering if it is related to the same race we have in bug 1328004 and bug 1319928. But this intermittent should have appeared sooner during december. Or may be there wasn't enough activity??
Looks like it is not bug 1328004, as the following push to try with a tentative fix still fails:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f3b0e847c7b82f176762fcd1188c1b9efb557b5d&selectedJob=67688753

If you have any guess of recent landing that would regress this test, that may help.

Comment 7

a year ago
30 failures in 128 pushes (0.234 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* autoland: 17
* mozilla-inbound: 7
* try: 2
* mozilla-central: 2
* graphics: 2

Platform breakdown:
* linux64: 30

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1329427&startday=2017-01-10&endday=2017-01-10&tree=all

Comment 8

a year ago
80 failures in 722 pushes (0.111 failures/push) were associated with this bug in the last 7 days. 

This is the #20 most frequent failure this week. 

** This failure happened more than 50 times this week! Resolving this bug is a high priority. **

Repository breakdown:
* autoland: 44
* mozilla-inbound: 22
* try: 7
* mozilla-central: 4
* graphics: 3

Platform breakdown:
* linux64: 80

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1329427&startday=2017-01-09&endday=2017-01-15&tree=all
It looks like this intermittent has been fixed between 9th and 11th.
I had bug 1328004 in mind, but it only landed on 12th.
bug 1324565 landed in this good timeframe but it has nothing to do, it just makes the toolbox faster to load on the inspector. If that's the bug which fixed this intermittent it means it will start to fail again if the inspector performances regress again.
Flags: needinfo?(poirot.alex)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Whiteboard: [stockwell fixed]
status-firefox52: --- → unaffected
status-firefox53: --- → fixed
status-firefox54: --- → fixed
You need to log in before you can comment on or make changes to this bug.