Closed Bug 1329538 Opened 3 years ago Closed 3 years ago

Make Adobe Primetime CDM non-visible in Firefox

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- wontfix
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: cpearce, Assigned: cpearce)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Henceforth we will no longer be shipping Adobe Primetime support in Firefox.

So we should flip the pref to make it not appear by default in the add-on manager plug-in list, and thus render it invisible and disabled by default.

The Adobe Primetime CDM was already not being downloaded by default (bug 1304899).

I will follow up in other bugs to remove the supporting code.
We'll want to uplift this to Firefox 52, as that's what's becoming ESR.
Comment on attachment 8824836 [details]
Bug 1329538 - Don't enable Adobe EME in release mozconfig.

https://reviewboard.mozilla.org/r/103116/#review104068
Attachment #8824836 - Flags: review?(mh+mozilla) → review+
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/800cdcd929ed
Don't enable Adobe EME in release mozconfig. r=glandium
https://hg.mozilla.org/mozilla-central/rev/800cdcd929ed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8824836 [details]
Bug 1329538 - Don't enable Adobe EME in release mozconfig.

We are removing Adobe Primetime EME support, and it's already disabled by default in 52.


Approval Request Comment
[Feature/Bug causing the regression]: Adobe Primetime EME support

[User impact if declined]: We'll show the Primetime EME CDM in the add-ons manager, disabled by default. We expect the download server for the Primetime CDM to stop working sometime soon, so we want to remove it from Firefox before 52 hits ESR, so we don't get stuck with a CDM we can't download in our add-ons UI for a year in ESR52.

[Is this code covered by automated tests?]: We have lots of EME mochitests. We have external-media-tests that verify that Netflix is not affected.

[Has the fix been verified in Nightly?]: I verified it this morning.

[Needs manual test from QE? If yes, steps to reproduce]: No.

[List of other uplifts needed for the feature/fix]: None.

[Is the change risky?]: No.

[Why is the change risky/not risky?]: This patch removes enabling Primetime EME in our Windows build config, so it's not enabled just like on Mac/Linux already. So this is low risk, as this code path is well tested on our other platforms.

[String changes made/needed]: None.
Attachment #8824836 - Flags: approval-mozilla-beta?
Attachment #8824836 - Flags: approval-mozilla-aurora?
Hi :cpearce,
According to comment #3, it seems to me that we only want this in 52, right? Since beta is 51 now, is it ok that we won't fix this in Beta51?
Flags: needinfo?(cpearce)
Comment on attachment 8824836 [details]
Bug 1329538 - Don't enable Adobe EME in release mozconfig.

disable adobe eme for aurora52
Attachment #8824836 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Gerry Chang [:gchang] from comment #8)
> Hi :cpearce,
> According to comment #3, it seems to me that we only want this in 52, right?
> Since beta is 51 now, is it ok that we won't fix this in Beta51?

We can let it ride in 52. I was off by one and mistakenly thought that 52 was currently in beta. So just uplifting to aurora 52 is fine.
Flags: needinfo?(cpearce)
Attachment #8824836 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
See Also: → 1337121
You need to log in before you can comment on or make changes to this bug.