3,600 instances of "Mask layer with no compositable host" emitted from gfx/layers/composite/LayerManagerComposite.cpp during linux64 debug testing

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
2 years ago
4 months ago

People

(Reporter: erahm, Assigned: jdescottes)

Tracking

(Blocks: 1 bug)

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
> 3140 WARNING: Mask layer with no compositable host: file gfx/layers/composite/LayerManagerComposite.cpp, line 1321

This warning [1] shows up in the following test suites:

>   3088 - test-linux64/debug-mochitest-devtools-chrome-e10s-5 dt5
>     46 - test-linux64/debug-mochitest-devtools-chrome-e10s-10 dt10
>      6 - test-linux64/debug-mochitest-devtools-chrome-e10s-2 dt2

It shows up in 37 tests. A few of the most prevalent:

>    153 - [e10s] devtools/client/animationinspector/test/browser_animation_target_highlighter_lock.js
>    144 - [e10s] devtools/client/animationinspector/test/browser_animation_controller_exposes_document_currentTime.js
>    126 - [e10s] devtools/client/animationinspector/test/browser_animation_timeline_shows_name_label.js
>    126 - [e10s] devtools/client/animationinspector/test/browser_animation_refresh_on_added_animation.js
>    117 - [e10s] devtools/client/animationinspector/test/browser_animation_timeline_shows_time_info.js
>    108 - [e10s] devtools/client/animationinspector/test/browser_animation_refresh_when_active.js
>    108 - [e10s] devtools/client/animationinspector/test/browser_animation_same_nb_of_playerWidgets_and_playerFronts.js
>    108 - [e10s] devtools/client/animationinspector/test/browser_animation_shows_player_on_valid_node.js
>    108 - [e10s] devtools/client/animationinspector/test/browser_animation_empty_on_invalid_nodes.js
>    108 - [e10s] devtools/client/animationinspector/test/browser_animation_timeline_shows_delay.js

[1] https://hg.mozilla.org/mozilla-central/annotate/2977ca122452/gfx/layers/composite/LayerManagerComposite.cpp#l1321
(Reporter)

Comment 1

2 years ago
Bisection points to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6bd789dee7a6fc7bc86934148b44421cbaf6ef48&tochange=d768c92253e97fafa7cee440573ac60f49a8c659 which is bug  1242986. Unfortunately that's just enabling e10s devtools tests, but at least we can tell this is e10s only.
Component: Developer Tools → Developer Tools: Animation Inspector
Inspector bug triage (filter on CLIMBING SHOES).
Priority: -- → P2
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
(Reporter)

Comment 3

2 years ago
This has become more verbose and is currently the 2nd largest warning during testing.
Summary: 3,100 instances of "Mask layer with no compositable host" emitted from gfx/layers/composite/LayerManagerComposite.cpp during linux64 debug testing → 3,600 instances of "Mask layer with no compositable host" emitted from gfx/layers/composite/LayerManagerComposite.cpp during linux64 debug testing
Comment hidden (mozreview-request)
(Reporter)

Comment 5

2 years ago
Zero warnings in a try run [1], so looks good from that angle.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=6b38788c5b1fec5c67f1f061c0ddab6bedf2410e
(Thanks for the try run erahm, I uploaded the patch in a hurry and forgot to add the investigation/explanation below)

I could reproduce the issue on a debug build on Ubuntu. The warnings occur even without opening the devtools during the test. 

Fiddling with the test page (), the warnings go away when removing the `border-radius` or the `background` property from the .ball class at:

http://searchfox.org/mozilla-central/rev/02a56df6474a97cf84d94bbcfaa126979970905d/devtools/client/animationinspector/test/doc_simple_animation.html#10

If we add an actual border to the element (such as 1px solid white), the warnings also disappear.
pbro: I propose we land this as a workaround and leave-open while we investigate for the real root cause of the issue.

Comment 7

2 years ago
mozreview-review
Comment on attachment 8829981 [details]
Bug 1329784 - avoid layout warnings in animation inspector debug tests;

https://reviewboard.mozilla.org/r/106934/#review108164

Sure. That works for me as a workaround. We could also remove the border-radius altogether, these tests don't care about the shape of the elements.
But, yeah, sounds like we should investigate the root cause causing the warning on Linux debug.
Attachment #8829981 - Flags: review?(pbrosset) → review+
Keywords: leave-open

Comment 8

2 years ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e00ee63857b5
avoid layout warnings in animation inspector debug tests;r=pbro
Created attachment 8830216 [details] [diff] [review]
bug1329784.bustage.patch

Tomcat: here's the follow up for the test failure. Sorry about that!
Flags: needinfo?(cbook)

Comment 10

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/23fce11bd83b
fix bustage in browser_animation_animated_properties_displayed.js;r=me a=tomcat
(In reply to Julian Descottes [:jdescottes] from comment #9)
> Created attachment 8830216 [details] [diff] [review]
> bug1329784.bustage.patch
> 
> Tomcat: here's the follow up for the test failure. Sorry about that!

landed :) and np :)
Flags: needinfo?(cbook)
No action left on DevTools side.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Keywords: leave-open
Resolution: --- → FIXED

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.