Crash in nsCOMPtr_base::assign_with_AddRef | mozilla::net::HttpBaseChannel::SetOriginalURI

RESOLVED DUPLICATE of bug 1324419

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 1324419
a year ago
a year ago

People

(Reporter: ting, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-0b91632f-0675-410e-a676-586b02170108.
=============================================================
Top #30 of Nightly 20170108030212 on Windows, 5 crashes from 2 installations.
Suspecting that the protocol handler is overloaded and the object is not nsHttpChannel.  The static_cast at [1] is wrong.

[1] https://hg.mozilla.org/mozilla-central/annotate/4ece183563a4/netwerk/protocol/http/HttpChannelParent.cpp#l369
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324419
You need to log in before you can comment on or make changes to this bug.