Intermittent test_screenshot.py TestScreenCaptureContent.test_capture_flags | AssertionError: u'iVBORw0KGgoA... (images unexpectedly equal))

NEW
Unassigned

Status

defect
P5
normal
3 years ago
2 days ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

(Depends on 1 bug, {intermittent-failure, leave-open})

Version 3
All
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 affected, firefox68 disabled, firefox69 affected)

Details

Attachments

(1 attachment)

The images (current vs. reference) are actually equal. Which means there is no border around the textfield and the cursor is also not drawn. If that fails more often I will have to take a look into this feature.
Summary: Intermittent test_screenshot.py TestScreenCaptureContent.test_capture_flags | AssertionError: → Intermittent test_screenshot.py TestScreenCaptureContent.test_capture_flags | AssertionError: u'iVBORw0KGgoA... (different images)
Summary: Intermittent test_screenshot.py TestScreenCaptureContent.test_capture_flags | AssertionError: u'iVBORw0KGgoA... (different images) → Intermittent test_screenshot.py TestScreenCaptureContent.test_capture_flags | AssertionError: u'iVBORw0KGgoA... (images unexpectedly equal))
This is a permafail for Fennec. So I'm going to disable the test completely for now via bug 1330616.
This might actually be a focus issue. I just noticed this failure locally while letting the test run in the background. As such the wanted focus in the text field will not appear.
Closing as intermittent has not been seen in last 45 days
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
This test has been disabled for Fennec immediately due to a high volume of failures. It hasn't been re-enabled / fixed since then, and as such didn't cause any OF entries.
Status: RESOLVED → REOPENED
OS: Unspecified → Android
Hardware: Unspecified → ARM
Resolution: WORKSFORME → ---
Sorry, my fault. The original platform for this failure is Win7 VM and not Android.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
OS: Android → Unspecified
Hardware: ARM → Unspecified
Resolution: --- → WORKSFORME

The test is still disabled, and was most likely also dependent on bug 1335085. I will try to re-enable it in combination with bug 1329424.

Status: RESOLVED → REOPENED
Depends on: 1335085, 1329424
Keywords: test-disabled
Priority: -- → P5
Resolution: WORKSFORME → ---

Fixed with the landing of my patch on bug 1329424.

Assignee: nobody → hskupin
Status: REOPENED → RESOLVED
Closed: 2 years ago3 months ago
Keywords: test-disabled
Priority: P5 → P1
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Actually not fixed yet. We still see this failure. I will observe how often and maybe we have to disable it again.

Status: RESOLVED → REOPENED
Priority: P1 → P5
Resolution: FIXED → ---
Target Milestone: mozilla69 → ---
Duplicate of this bug: 1557969

I'm currently not working on this bug given that it doesn't have high priority.

Assignee: hskupin → nobody
Status: REOPENED → NEW
OS: Unspecified → Windows
Hardware: Unspecified → All

This seems to be a perma failure with my patches from bug 1559592 applied.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1e793f25d3dbc21e12d70fa7aa26147ae540fa6e&searchStr=marionette%2Cwin

Now that this is reproducible, I could figure out what's wrong.

I would suggest that we skip the test again for now, means reverting the code removal from:
https://hg.mozilla.org/mozilla-central/rev/8eb5ac3760e7

Once my patch from bug 1559592 landed we can then investigate.

Depends on: 1559592

Temporarily skip on Windows to get the new screenshot API landed.
Given that this change makes this failure permanent it should be
easier for investigation after its landing.

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b0c482b4235
[marionette] Temporarily skip TestScreenCaptureContent.test_capture_flags on Windows. r=webdriver-reviewers,jgraham

The problem here is that we are trying to capture the caret but given that it is blinking the test can intermittently fail. We are currently discussing this over on bug 1559592, and maybe we should just delete this test.

You need to log in before you can comment on or make changes to this bug.