Closed Bug 1330592 Opened 5 years ago Closed 5 years ago

[Stylo] Talos job "s" makes stylo crash

Categories

(Testing :: Talos, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: shinglyu, Unassigned)

References

Details

https://treeherder.mozilla.org/#/jobs?repo=try&revision=cc113d4a2d9acd3eb7cd30542bf1f079e7ae5705&selectedJob=66082391

PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]
TEST-UNEXPECTED-ERROR | tart | Found crashes after test run, terminating test
Traceback (most recent call last):
Return code: 2
# TBPL FAILURE #
Component: CSS Parsing and Computation → Talos
Product: Core → Testing
The stack from the log starts with:

02:59:35     INFO -  PROCESS-CRASH | tart | application crashed [@ style::properties::cascade]

02:59:35     INFO -  Crash dump filename: /tmp/tmpE1wqHu/profile/minidumps/27a6aaf0-c606-b6e1-60bc49c0-4bf2b6b7.dmp

02:59:35     INFO -  Operating system: Linux

02:59:35     INFO -                    0.0.0 Linux 3.2.0-76-generic #111-Ubuntu SMP Tue Jan 13 22:16:09 UTC 2015 x86_64

02:59:35     INFO -  CPU: amd64

02:59:35     INFO -       family 6 model 30 stepping 5

02:59:35     INFO -       8 CPUs

02:59:35     INFO -  GPU: UNKNOWN

02:59:35     INFO -  Crash reason:  SIGSEGV

02:59:35     INFO -  Crash address: 0xb8

02:59:35     INFO -  Process uptime: not available

02:59:35     INFO -  Thread 0 (crashed)

02:59:35     INFO -   0  libxul.so!style::properties::cascade [arc.rs : 317 + 0x0]

02:59:35     INFO -      rax = 0x0000000000000020   rdx = 0x00007fb115401bd0

02:59:35     INFO -      rcx = 0x0000000000000000   rbx = 0x00007fb0eed31ac0

02:59:35     INFO -      rsi = 0x0000000000000000   rdi = 0x00007fb11c600108

02:59:35     INFO -      rbp = 0x00007fff338c30c0   rsp = 0x00007fff338c2d10

02:59:35     INFO -       r8 = 0x0000000000000000    r9 = 0x0000000000000001

02:59:35     INFO -      r10 = 0x00000000000001a0   r11 = 0x0000000000000021

02:59:35     INFO -      r12 = 0x0000000000000000   r13 = 0x00007fb0eed31ad8

02:59:35     INFO -      r14 = 0x00007fb0eca4fe80   r15 = 0x0000000000000002

02:59:35     INFO -      rip = 0x00007fb113c6625c

02:59:35     INFO -      Found by: given as instruction pointer in context

02:59:35     INFO -   1  libxul.so!geckoservo::glue::Servo_ComputedValues_GetForAnonymousBox [stylist.rs:cc113d4a2d9a : 302 + 0x2f]

02:59:35     INFO -      rbx = 0x00007fff338c30e0   rbp = 0x00007fff338c32d0

02:59:35     INFO -      rsp = 0x00007fff338c30d0   r12 = 0x00007fb0ecacdcf8

02:59:35     INFO -      r13 = 0x00007fb0fe430240   r14 = 0x00007fb1068ce2b0

02:59:35     INFO -      r15 = 0x0000000000000000   rip = 0x00007fb113ad8cdc

02:59:35     INFO -      Found by: call frame info

02:59:35     INFO -   2  libxul.so!mozilla::ServoStyleSet::ResolveAnonymousBoxStyle [ServoStyleSet.cpp:cc113d4a2d9a : 249 + 0x5]

02:59:35     INFO -      rbx = 0x0000000000000000   rbp = 0x00007fff338c3330

02:59:35     INFO -      rsp = 0x00007fff338c32e0   r12 = 0x0000000000000000

02:59:35     INFO -      r13 = 0x00007fff338c3378   r14 = 0x00007fb0eed31a50

02:59:35     INFO -      r15 = 0x00007fb0fe430240   rip = 0x00007fb11284df68

02:59:35     INFO -      Found by: call frame info

02:59:35     INFO -   3  libxul.so!mozilla::StyleSetHandle::Ptr::ResolveAnonymousBoxStyle [StyleSetHandleInlines.h:cc113d4a2d9a : 128 + 0x5]

02:59:35     INFO -      rbx = 0x00007fff338c3378   rbp = 0x00007fff338c3350

02:59:35     INFO -      rsp = 0x00007fff338c3340   r12 = 0x00007fb0eed78500

02:59:35     INFO -      r13 = 0x0000000000000000   r14 = 0x000000000000b400

02:59:35     INFO -      r15 = 0x00007fb0ecbc6c00   rip = 0x00007fb11290d25f

02:59:35     INFO -      Found by: call frame info

02:59:35     INFO -   4  libxul.so!nsCSSFrameConstructor::ConstructRootFrame [nsCSSFrameConstructor.cpp:cc113d4a2d9a : 2714 + 0x19]

02:59:35     INFO -      rbx = 0x00007fb0eed31a51   rbp = 0x00007fff338c33a0

02:59:35     INFO -      rsp = 0x00007fff338c3360   r12 = 0x00007fb0eed78500

02:59:35     INFO -      r13 = 0x0000000000000000   r14 = 0x000000000000b400

02:59:35     INFO -      r15 = 0x00007fb0ecbc6c00   rip = 0x00007fb112932041

02:59:35     INFO -      Found by: call frame info

02:59:35     INFO -   5  libxul.so!mozilla::PresShell::Initialize [PresShell.cpp:cc113d4a2d9a : 1683 + 0x9]

02:59:35     INFO -      rbx = 0x00007fff338c33d0   rbp = 0x00007fff338c3420

02:59:35     INFO -      rsp = 0x00007fff338c33b0   r12 = 0x0000000000000000

02:59:35     INFO -      r13 = 0x0000000000000000   r14 = 0x000000000000b400

02:59:35     INFO -      r15 = 0x00007fb0ecbc6c00   rip = 0x00007fb11290133c

02:59:35     INFO -      Found by: call frame info
My guess is that there's probably an assertion that's triggering first, but we don't see it since it's an opt build.

Shing, is it possible to run talos locally with --enable-debug builds? If so, it's probably worth reproducing this failure (and others) in that configuration, since that'll give us more to work with, and (hopefully) map to other existing crashtest failures that we have on file.
The crash is gone after update https://treeherder.mozilla.org/#/jobs?repo=try&revision=a5073a9f2756096826ebf3c5cb5596db31207f02
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.