Closed Bug 1330885 Opened 8 years ago Closed 7 years ago

stylo: sibling combinators in selector do not respond to DOM tree change

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1345950
Tracking Status
firefox53 --- affected

People

(Reporter: xidorn, Unassigned)

References

Details

Please see layout/style/test/test_bug229915.html

This test is checking that sibling combinators (next-sibling combinator "+" and following-sibling combinator "~") correctly respond to inserting, replacing, and removing elements.

We currently fail 5 out of 6 checks after the mutation. (Actually I guess we are failing all. The only passed one is probably just never changed since the very beginning.)
I guess this belongs to incremental restyling, so I guess bholley may want to take a look?
Flags: needinfo?(bobbyholley)
We need to do similar things in ServoRestyleManager::{RestyleForInsertOrChange,ContentRemoved} that we do in RestyleManager, where we explicitly queue up restyles to handle ~ and other combinators.
(In reply to Cameron McCormack (:heycam) from comment #2)
> We need to do similar things in
> ServoRestyleManager::{RestyleForInsertOrChange,ContentRemoved} that we do in
> RestyleManager, where we explicitly queue up restyles to handle ~ and other
> combinators.

Yeah this is bug 1297899, which is some hopefully-straightforward refactoring to share more code between the RestyleManager implementations. I can do it at some point if somebody else doesn't get to it first, but I've got a few things on my plate before then.
Depends on: 1297899
Flags: needinfo?(bobbyholley)
Hm, the dep was fixed, but the test is still failing according to stylo-failures.md.
Priority: -- → P2
(In reply to Cameron McCormack (:heycam) from comment #5)
> It might be bug 1338982.

Yeah I think that's probably right.
Depends on: 1338982
Looks like landing bug 1345950 fixed the test that was failing here:

https://hg.mozilla.org/integration/autoland/rev/069fe1ab5515
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.