Bug 1321197 (stylo-style-mochitest)

[meta] stylo: Have stylo pass all style system mochitests

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: xidorn, Assigned: xidorn)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

2 years ago
I'm going to use this bug to track issues blocking running style system tests with stylo.

I think we should do the following:
1. fix crash bugs found from running the tests
2. create a new test task which runs a subset of style system tests on ci
3. fix other bugs identified by the tests
(Assignee)

Updated

2 years ago
Depends on: 1321206
(Assignee)

Updated

2 years ago
Depends on: 1324627
(Assignee)

Updated

2 years ago
Depends on: 1323654
(Assignee)

Updated

2 years ago
Depends on: 1324632
(Assignee)

Updated

2 years ago
Depends on: 1324988
(Assignee)

Updated

2 years ago
Depends on: 1323655
(Assignee)

Updated

2 years ago
Depends on: 1290224
(Assignee)

Updated

2 years ago
Depends on: 1302945, 1288269
(Assignee)

Updated

2 years ago
Depends on: 1323665
(Assignee)

Updated

2 years ago
Depends on: 1323715
(Assignee)

Updated

2 years ago
Depends on: 1328499
(Assignee)

Updated

2 years ago
Depends on: 1328503
(Assignee)

Updated

2 years ago
Depends on: 1328505
(Assignee)

Updated

2 years ago
Depends on: 1328507
(Assignee)

Updated

2 years ago
Depends on: 1328511
(Assignee)

Updated

2 years ago
Depends on: 1323678
(Assignee)

Updated

2 years ago
Depends on: 1292283
(Assignee)

Updated

2 years ago
Depends on: 1328512
(Assignee)

Updated

2 years ago
Depends on: 1328513
(Assignee)

Updated

2 years ago
Depends on: 1329533
Assignee: nobody → xidorn+moz
Blocks: 1330412
No longer blocks: 1243581
Priority: -- → P1
Depends on: 1289935
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1289935
(Assignee)

Updated

2 years ago
Depends on: 1330503
(Assignee)

Updated

2 years ago
Depends on: 1330824
(Assignee)

Updated

2 years ago
Depends on: 1330825
(Assignee)

Updated

2 years ago
Depends on: 1330874
(Assignee)

Updated

2 years ago
Depends on: 1330885
(Assignee)

Updated

2 years ago
Depends on: 1331291
(Assignee)

Updated

2 years ago
Depends on: 1331294
(Assignee)

Updated

2 years ago
Depends on: 1331301
(Assignee)

Updated

2 years ago
Depends on: 1310886
(Assignee)

Updated

2 years ago
Depends on: 1331516
(Assignee)

Updated

2 years ago
Depends on: 1331529
(Assignee)

Updated

2 years ago
Depends on: 1290237
(Assignee)

Updated

2 years ago
Depends on: 1331543
(Assignee)

Updated

2 years ago
Depends on: 1331903
(Assignee)

Updated

2 years ago
Depends on: 1330172
(Assignee)

Updated

2 years ago
Depends on: 1332969
(Assignee)

Updated

2 years ago
Alias: stylo-style-mochitest
(Assignee)

Updated

2 years ago
Depends on: 1296477
(Assignee)

Updated

2 years ago
Depends on: 1335252
(Assignee)

Updated

2 years ago
Depends on: 1334982
(Assignee)

Updated

2 years ago
Depends on: 1335261
(Assignee)

Updated

2 years ago
Depends on: 1335987
(Assignee)

Updated

2 years ago
Depends on: 1335990
(Assignee)

Updated

2 years ago
Depends on: 1234357
(Assignee)

Updated

2 years ago
Depends on: 1336863
(Assignee)

Updated

2 years ago
Depends on: 1336891
(Assignee)

Comment 2

2 years ago
Filed a Servo side meta bug for this.
(Assignee)

Updated

2 years ago
Depends on: 1337068
(Assignee)

Updated

2 years ago
Depends on: 1337248
(Assignee)

Updated

2 years ago
No longer depends on: 1337248
(Assignee)

Updated

2 years ago
Summary: [meta] stylo: Run style system mochitests on stylo → [meta] stylo: Have style system mochitests green with stylo
(Assignee)

Updated

2 years ago
Depends on: 1337599
(Assignee)

Updated

2 years ago
No longer depends on: 1328507
(Assignee)

Updated

2 years ago
No longer depends on: 1328511
(Assignee)

Updated

2 years ago
No longer depends on: 1290224
(Assignee)

Updated

2 years ago
No longer depends on: 1328505
(Assignee)

Updated

2 years ago
No longer depends on: 1328499
(Assignee)

Updated

2 years ago
No longer depends on: 1323665
(Assignee)

Updated

2 years ago
No longer depends on: 1292283
(Assignee)

Updated

2 years ago
Depends on: 1337611
(Assignee)

Updated

2 years ago
Depends on: 1337612
(Assignee)

Updated

2 years ago
Depends on: 1324704
(Assignee)

Updated

2 years ago
Depends on: 1324647
(Assignee)

Updated

2 years ago
Depends on: 1337615
(Assignee)

Updated

2 years ago
No longer depends on: 1337611
(Assignee)

Updated

2 years ago
No longer depends on: 1337612
(Assignee)

Updated

2 years ago
Summary: [meta] stylo: Have style system mochitests green with stylo → [meta] stylo: Have stylo pass all style system mochitests
(Assignee)

Updated

2 years ago
Depends on: 1337655
(Assignee)

Updated

2 years ago
Depends on: 1337674
(Assignee)

Updated

2 years ago
Depends on: 1338425
Now that this job is running on autoland / mc, what do you think about temporarily disabling test_align_justify_computed_values.html and test_acid3_test46.html so that we can keep it green?
Flags: needinfo?(xidorn+moz)
(Assignee)

Comment 4

2 years ago
test_align_justify_computed_values.html and test_acid3_test46.html are not the only mochitests currently fail. There are tons of tests are still failing (see https://gist.github.com/upsuper/082268f59e6f267d5a466c2cbe698e58). Only them showing up in the panel is just because they are the first two tests run in the task and failures from them have already run out of space of that panel.

In addition to failures, there are also many non-fatal assertions (see bug 1337615).

So making that task green isn't that trivial. We may need to disable a wide range of mochitests to make it green (not sure how many, but we would lose the biggest tests including test_{inherit,initial,value}_{storage,computation}.html).

I've filed bug 1337674 to figure out the best path to green the task with the known failure list. But I'm unsure about what is the most helpful way.
Flags: needinfo?(xidorn+moz)
(Assignee)

Updated

2 years ago
Depends on: 1340683
(Assignee)

Updated

2 years ago
Depends on: 1341195
(Assignee)

Updated

2 years ago
No longer depends on: 1328503
Depends on: 1343452
Priority: P1 → P5
(Assignee)

Updated

2 years ago
Depends on: 1347381
(Assignee)

Updated

2 years ago
Depends on: 1347398
(Assignee)

Updated

2 years ago
Depends on: 1347409
(Assignee)

Updated

2 years ago
Depends on: 1347412
(Assignee)

Updated

2 years ago
Depends on: 1331530
(Assignee)

Updated

2 years ago
No longer depends on: 1338425
(Assignee)

Updated

2 years ago
Depends on: 1347821
Depends on: 1348022
Depends on: 1348030
(Assignee)

Updated

2 years ago
Depends on: 1348165
(Assignee)

Updated

2 years ago
Depends on: 1348173
(Assignee)

Updated

2 years ago
Depends on: 1352669
(Assignee)

Updated

2 years ago
Depends on: 1352968
(Assignee)

Updated

2 years ago
Depends on: 1354998
(Assignee)

Updated

2 years ago
Depends on: 1355001
(Assignee)

Updated

2 years ago
Depends on: 1355005
(Assignee)

Updated

2 years ago
Depends on: 1355014
(Assignee)

Updated

2 years ago
Depends on: 1355017
(Assignee)

Updated

2 years ago
Depends on: 1355345
(Assignee)

Updated

2 years ago
Depends on: 1355352
(Assignee)

Updated

2 years ago
Depends on: 1355356
(Assignee)

Updated

2 years ago
Depends on: 1355364
(Assignee)

Updated

2 years ago
Depends on: 1355366
(Assignee)

Updated

2 years ago
Depends on: 1355368
(Assignee)

Updated

2 years ago
Depends on: 1355388
(Assignee)

Updated

2 years ago
Depends on: 1345697
(Assignee)

Updated

2 years ago
Depends on: 1355394
(Assignee)

Updated

2 years ago
Depends on: 1355402
(Assignee)

Updated

2 years ago
Depends on: 1355408
(Assignee)

Updated

2 years ago
Depends on: 1355412
(Assignee)

Updated

2 years ago
Depends on: 1355683
(Assignee)

Updated

2 years ago
Depends on: 1355715
(Assignee)

Updated

2 years ago
Depends on: 1355716
(Assignee)

Updated

2 years ago
Depends on: 1355721
(Assignee)

Updated

2 years ago
Depends on: 1355724
(Assignee)

Updated

2 years ago
Depends on: 1355734
(Assignee)

Updated

2 years ago
Depends on: 1356072
(Assignee)

Updated

2 years ago
Depends on: 1356087
Depends on: 1353191
(Assignee)

Updated

2 years ago
Depends on: 1356104
(Assignee)

Updated

2 years ago
Depends on: 1356174
(Assignee)

Updated

2 years ago
Depends on: 1356494
Depends on: 1358330
Depends on: 1358353
(Assignee)

Updated

2 years ago
Depends on: 1360488
Depends on: 1361663
Depends on: 1361938
Depends on: 1356916
Depends on: 1362914
(Assignee)

Updated

2 years ago
Depends on: 1363590
(Assignee)

Updated

2 years ago
Depends on: 1363596
(Assignee)

Updated

2 years ago
Depends on: 1363968
(Assignee)

Updated

2 years ago
Depends on: 1363971
(Assignee)

Updated

2 years ago
Depends on: 1363974
(Assignee)

Updated

2 years ago
Depends on: 1363984
(Assignee)

Updated

2 years ago
Depends on: 1363986
(Assignee)

Updated

2 years ago
Depends on: 1364009
(Assignee)

Updated

2 years ago
Depends on: 1364260
(Assignee)

Updated

2 years ago
Depends on: 1364273
(Assignee)

Updated

2 years ago
Depends on: 1364286
(Assignee)

Updated

2 years ago
Depends on: 1364289
(Assignee)

Updated

2 years ago
Depends on: 1364799
(Assignee)

Updated

2 years ago
Depends on: 1366157
(Assignee)

Updated

2 years ago
No longer depends on: 1355683
(Assignee)

Updated

2 years ago
Depends on: 1366544
(Assignee)

Updated

2 years ago
No longer depends on: 1337655
(Assignee)

Updated

2 years ago
Depends on: 1363349
Depends on: 1366934
(Assignee)

Updated

2 years ago
Depends on: 1366956
(Assignee)

Updated

2 years ago
Depends on: 1366961
(Assignee)

Updated

2 years ago
Depends on: 1347270
Depends on: 1367028
(Assignee)

Updated

2 years ago
Depends on: 1367274
(Assignee)

Updated

2 years ago
Depends on: 1367299
(Assignee)

Updated

2 years ago
Depends on: 1367306
(Assignee)

Updated

2 years ago
Depends on: 1367310
(Assignee)

Updated

2 years ago
Depends on: 1367312
(Assignee)

Updated

2 years ago
Depends on: 1367315
(Assignee)

Updated

2 years ago
Depends on: 1363292
(Assignee)

Updated

2 years ago
Depends on: 1188074
No longer blocks: 1243581
(Assignee)

Updated

2 years ago
No longer depends on: 1234357
(Assignee)

Updated

2 years ago
Depends on: 1382077
(Assignee)

Updated

2 years ago
Depends on: 1382078
(Assignee)

Updated

2 years ago
Depends on: 1382080
(Assignee)

Updated

2 years ago
Depends on: 1382102
Depends on: 1389439
(Assignee)

Comment 5

5 months ago
Mark fixed as a tracking bug.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.