Closed Bug 1330972 Opened 3 years ago Closed 3 years ago

18.39 - 19.46% tcanvasmark (windows7-32) regression on mozilla-beta push ce55e4d27603 (Mon Jan 9 2017)

Categories

(Firefox :: Untriaged, defect)

51 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push ce55e4d276031458f0730d481acff05d7c797038. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 19%  tcanvasmark summary windows7-32 pgo e10s     9117.33 -> 7343.46
 18%  tcanvasmark summary windows7-32 pgo          8858.83 -> 7229.71

Improvements:

  7%  tsvgr_opacity summary linux64 pgo e10s     334.05 -> 309.76
  7%  tsvgr_opacity summary linux64 pgo          376.74 -> 349.56


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=4794

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
this is a set of commits on mozilla-beta, we don't see a windows8 regression in tcanvasmark, but retriggers before/after the change shows this is a consistent set of data:
https://treeherder.mozilla.org/perf.html#/graphs?timerange=604800&series=%5Bmozilla-beta,2255fb569975ea2bf55698d78ae7cf4fa267feee,1,1%5D&series=%5Bmozilla-beta,6b0602b146e4c2d01b6fe4c4c187bbdecff6c389,1,1%5D
there is a list of changes:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=adb88a603efb0efe74e23cd87066317bea2c82f7&tochange=ce55e4d276031458f0730d481acff05d7c797038

I see a few skia/* changes, lets start there.

:lsalzman, can you look at your patches from bug 1329309 and bug 1318769  to see if one of them could cause the windows 7 only regression in tcanvasmark?
Flags: needinfo?(lsalzman)
This is from bug 1329309, which was necessary to resolve crashes caused by that particular deprecated code. Yes, this will cause a temporary canvasmark regression that will only affect 51, since 52+ have the Skia update that resolves this.

However, since this is only regarding 51, and given the complexity of backporting fixes from 52 for this issue involving a Skia update, I think this is best handled as a WONTFIX and we will accept the regression.
Flags: needinfo?(lsalzman)
Thanks Lee for knowing about this.  Based on aurora/trunk data I do not see this regression at all.

Feel free to wontfix this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.