[tracking] BrowserAction API support for Android WebExtensions

RESOLVED DUPLICATE of bug 1330159

Status

()

Toolkit
WebExtensions: Android
P2
normal
RESOLVED DUPLICATE of bug 1330159
3 months ago
a month ago

People

(Reporter: mattw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [browserAction]triaged)

(Reporter)

Description

3 months ago
This bug is meant for tracking the implementation of the BrowserAction API on Fennec.

This API allows the developer to add an icon, which when clicked on can either perform an action or open up a popup. Therefore, we need help figuring out where to put this icon, as well as what to do about the browser action popup.
(Reporter)

Updated

3 months ago
Priority: P5 → P2
(Reporter)

Updated

3 months ago
Depends on: 1331742
(Reporter)

Updated

3 months ago
Depends on: 1331746

Comment 1

2 months ago
From what I can tell the PageAction API is already implemented. So I'm assuming that the only reason this hasn't been implemented yet is because no one can think of a good way of where to place the icon? 
I feel like the BrowserAction is extremely important. (Way more important than the PageAction.) I mean I've seen lots of extensions that require you to click the BrowserAction to enable/disable it and also extensions that use the popup to let the user configure the settings.  
Also, I feel like the lack of BrowserAction pushes extension developers into a corner where they start misusing the PageAction to compensate. 

And to throw some ideas for the icon placement into the room:  
 - put them below the navigation icons in the menu
 - put a general icon next to the navigation bar that toggles a popup containing all the BrowserAction icons

Comment 2

2 months ago
(In reply to t-v.k from comment #1)
> From what I can tell the PageAction API is already implemented. So I'm
> assuming that the only reason this hasn't been implemented yet is because no
> one can think of a good way of where to place the icon? 

No, we've already decided that these would appear in the main menu. It hasn't been implemented yet because there have been other priorities.

Comment 3

2 months ago
Oh alright. Where can I read up on the development?
(Reporter)

Comment 4

a month ago
Here is the best place to follow the development -- there just hasn't been much lately, but you can expect to see more updates here over the next few weeks.
(Reporter)

Comment 5

a month ago
Setting this bug to "Unassigned" since it's a tracker.
Assignee: mwein → nobody
(Reporter)

Comment 6

a month ago
Moving work on this bug to bug 1330159.
No longer blocks: 1185785
Status: NEW → RESOLVED
Last Resolved: a month ago
No longer depends on: 1331742, 1331746
Resolution: --- → DUPLICATE
Duplicate of bug: 1330159
You need to log in before you can comment on or make changes to this bug.