Highlight All can't be enabled without reloading the page

ASSIGNED
Assigned to

Status

()

ASSIGNED
2 years ago
2 years ago

People

(Reporter: bj, Assigned: mikedeboer)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 disabled)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Observations:
- Start Firefox with a new profile.
- Visit https://bugzilla.mozilla.org/.
- Search "f". The page is dimmed, the first F is colored and the second F is un-dimmed. The Highlight All button has a box around it.

- Click "Highlight All".
 -- Expected: Page still dimmed, first F colored. Highlight All not boxed.
 -- Actual: Page not dimmed (undimmed when the click happens). First F is selected, but blue instead of yellow as before. Highlight All not boxed.

- Click "Highlight All" a second time.
 -- Expected: Same appearance as before "Highlight All" was clicked the first time.
 -- Actual: The "Highlight All" button is boxed, but otherwise no noticable change from before the second click. The second F isn't highlighted.

- Clicking Highligh All at this point several times just changes the highlighting around the Highlight All button.

- Press Enter with the search text box selected.
 -- Expected: Appearance as with the first time a search string is entered.
 -- Actual: The page is dimmed again and the next "F" on the page is colored. But Hightlight All is disabled, not matter how the button appears.

- To get Highlight All to work again: Click the Highlight All button to make it appear boxed. Then reload the page, display a different page, or switch to a different tab.
 -- Note: Apparently the state of the Highlight All button is preserved (for more than just the display of the button) but it takes refreshing the page to see the effect.

Observations with Linux using XFCE. The notes above were taken with a new profile.

I don't know whether the fix for bug 1316514 changed some details of the behavior, but the major point (that Highlight All disabled on click but didn't re-enable for that page) has been a problem for a while. I was hoping the fix for bug 1316514 would address the issue.
(Reporter)

Comment 1

2 years ago
Created attachment 8826996 [details]
Screen shot where the visual state of the Highlight All button indicates it is enabled but it isn't working
(Reporter)

Updated

2 years ago
Flags: needinfo?(mdeboer)
(Assignee)

Comment 2

2 years ago
Thanks for filing, BJ. I'll take a look at it soon.

Is this reproducable with findbar.modalHighlight set to `false`?
Blocks: 1291278
Flags: needinfo?(mdeboer) → needinfo?(bj)
(Assignee)

Updated

2 years ago
Flags: needinfo?(mdeboer)
(Reporter)

Comment 3

2 years ago
The problem is related to findbar.modalHighlight set to true. I switched off findbar.modalHighlight and I am able to disable and enable highlight all by clicking the Highlight All button.

(I didn't test all the varfindbar.modalHighlightiations in my initial report so some details might be existing behavior.)
Flags: needinfo?(bj)
(Assignee)

Updated

2 years ago
Assignee: nobody → mdeboer
Flags: needinfo?(mdeboer)
(Assignee)

Updated

2 years ago
Blocks: 1316514
Summary: Highlight All can't be enabled without loading the page → Highlight All can't be enabled without reloading the page
(Assignee)

Updated

2 years ago
status-firefox53: affected → disabled
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
You need to log in before you can comment on or make changes to this bug.