Closed Bug 1331357 Opened 5 years ago Closed 5 years ago

Intermittent linux-qr debug | REFTEST TEST-UNEXPECTED-FAIL tests/reftest/tests/editor/reftests/caret_on_presshell_reinit-ref.html | assertion count 2 is more than expected 0 to 1 assertions

Categories

(Core :: Graphics: WebRender, defect, P3)

53 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [gfx-noted])

Attachments

(1 file)

See https://treeherder.mozilla.org/#/jobs?repo=graphics&fromchange=648d37cd4daa9a4bb3a6fc0c3ccefc96623d78a2&filter-searchStr=quantum%20ru8&selectedJob=68988061

I'm doing retriggers to track down if it's a regression. It only started showing up recently so I'm hopeful we'll isolate the change that introduced it.
Happening on R8 as well, not just Ru8.
Summary: Intermittent linux-qr debug Ru8 | REFTEST TEST-UNEXPECTED-FAIL tests/reftest/tests/editor/reftests/caret_on_presshell_reinit-ref.html | assertion count 2 is more than expected 0 to 1 assertions → Intermittent linux-qr debug | REFTEST TEST-UNEXPECTED-FAIL tests/reftest/tests/editor/reftests/caret_on_presshell_reinit-ref.html | assertion count 2 is more than expected 0 to 1 assertions
Looks like it's actually been happening for a while, but maybe got more frequent recently.
So the "assertion count 2" is because the same assertion is triggering twice. The test in question already has an asserts-if(0-1) to catch one instance of the assertion. I think it's reasonable to expand it to 0-2 to catch the two instances, although maybe just for webrender. The assertion is the one at [1].

[1] https://dxr.mozilla.org/mozilla-central/rev/0eef1d5a39366059677c6d7944cfe8a97265a011/layout/generic/nsTextFrame.cpp#2931
For reference the asserts-if(0-1) was added in bug 1218032, there is some discussion in bug 1218032 comment 29 and bug 1218032 comment 41. It looks like it was supposed to be investigated but never was.
Assignee: nobody → bugmail
Comment on attachment 8837662 [details]
Bug 1331357 - Expand number of allowed assertions during a reftest, because in QR builds we sometimes get two.

https://reviewboard.mozilla.org/r/112732/#review114478
Attachment #8837662 - Flags: review?(masayuki) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/05efc3638dd9
Expand number of allowed assertions during a reftest, because in QR builds we sometimes get two. r=masayuki
https://hg.mozilla.org/mozilla-central/rev/05efc3638dd9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Pushed by mchang@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/4b47e1e71f37
Expand number of allowed assertions because sometimes we get 3 instead of 2. r=masayuki
Comment 11 landed with the wrong bug number. That should have gone on bug 1350004 instead. I backed it out and relanded with the right bug number. Backout is https://hg.mozilla.org/projects/graphics/rev/a61c5c0ac88bf104f0ccd1c92253f1138919c0f8.
You need to log in before you can comment on or make changes to this bug.