Creating a WebGL context can cause a sync IPC to the parent process

RESOLVED FIXED in Firefox 53

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: Away for a while, Assigned: Away for a while)

Tracking

(Blocks: 1 bug)

unspecified
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 months ago
See this profile for example, where the Msg_GetGraphicsFeatureStatus sync IPC message causes a 1 second pause: <https://clptr.io/2jkHPo0>

This is caused by GfxInfoBase::GetFeatureStatus() delegating to the parent process.  Since the feature status doesn't change after startup, I have a patch that replaces this sync IPC with another sync IPC at startup where we ask the parent process to compute the status of all features, and cache them in the content process.  Since we already do sync IPC at content process startup, this should improve our responsiveness.
(Assignee)

Comment 1

11 months ago
Created attachment 8827540 [details] [diff] [review]
Avoid doing sync IPC to the parent process for getting gfx feature status
Attachment #8827540 - Flags: review?(jmuizelaar)
Attachment #8827540 - Flags: review?(jmuizelaar) → review?(dvander)
Comment on attachment 8827540 [details] [diff] [review]
Avoid doing sync IPC to the parent process for getting gfx feature status

Review of attachment 8827540 [details] [diff] [review]:
-----------------------------------------------------------------

Seems reasonable.
Attachment #8827540 - Flags: review?(dvander) → review+

Comment 3

11 months ago
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2f86db66e8e4
Avoid doing sync IPC to the parent process for getting gfx feature status; r=dvander
(Assignee)

Updated

11 months ago
Depends on: 1332036

Comment 4

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2f86db66e8e4
Status: NEW → RESOLVED
Last Resolved: 11 months ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.