Temporary permissions remain after reloading the page using the tab context menu

VERIFIED FIXED in Firefox 53

Status

()

defect
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: hani.yacoub, Assigned: johannh)

Tracking

(Blocks 1 bug)

53 Branch
Firefox 53
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox53 verified, firefox54 verified)

Details

(Whiteboard: [fxprivacy])

Attachments

(1 attachment)

[Affected versions]: 
Nightly 53.0a1

[Affected platforms]:
All platforms: Ubuntu 16.04 x64, Windows 10 x 64, Mac OS X 10.11

[Steps to reproduce]:
1. Go to permission.site and click on "Notification".
2. Uncheck "Remember this decicsion" and click on "Don't Allow".
3. Reload the page.

[Expected result]:
In the address bar near the "i" you the notification icon in a grey color and with a stripe over it shouldn't be displayed.
In control center under the Permissions "You have not granted this site any special permissions" message is displayed.

[Actual result]:
In the address bar near the "i" you see a notification icon that in a grey color and with a stripe over it.
In control center unde permissions the status is Block Temporarily.
Blocks: 1188147
I can't reproduce :/

Can you try with a different permission?
It's reproducible with all the permissions, but you have to reload the tab not refreshing the page.
1. Right click on the tab.
2. Click on "Reload Tab".
This happens because http://searchfox.org/mozilla-central/source/browser/base/content/tabbrowser.xml#3078 is not calling BrowserReload, which is the only place we're listing for a reload currently. Need to fix that.
Whiteboard: [fxprivacy] [triage]
Summary: Temporarily permissions remain after reloading the page → Temporary permissions remain after reloading the page using the tab context menu
Priority: -- → P1
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Comment on attachment 8828720 [details]
Bug 1331921 - Hide temporary permissions on tab reload through the context menu.

https://reviewboard.mozilla.org/r/106028/#review107080

Looks good, thanks for including a test.
Attachment #8828720 - Flags: review?(florian) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea5dac2d3a45
Hide temporary permissions on tab reload through the context menu. r=florian
https://hg.mozilla.org/mozilla-central/rev/ea5dac2d3a45
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Flags: qe-verify+
Build ID: 20170124030205
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Tested this issue on Windows 10 x 64, Mac OS X 10.11 and Ubuntu 16.04 x64 on Firefox Nightly 53.0a1, Firefox Nightly 54.0a1 and Aurora 53.0a2 and I confirm that it's not reproducible any more.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.