Closed Bug 1332136 Opened 3 years ago Closed 3 years ago

H.265/HEVC Streaming not working

Categories

(Firefox for Android :: Audio/Video, defect, P5)

Other
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox50 --- affected
firefox51 --- affected
firefox52 --- affected
firefox53 --- affected

People

(Reporter: lgbrowser5, Unassigned)

References

()

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; CNS_UA; GWX:MANAGED; AD_LOGON=4C47452E4E4554; rv:11.0) like Gecko

Steps to reproduce:

1. Platform Version (M): NOS(7.0)
2. Firefox version (M): Firefox 50.1, Firefox Beta 51.0
3. Reproducible on LG Ref. device (M) : Yes / G5 device
4. Reproduce rate (M) : 10/10
5. Issue Reported (M) : Carrier
6. Issue Description (Wrong behavior) (M) : H.265/HEVC Streaming not working
Firefox displays the message 'No video with supported format and MIME type found'
7. Expected behavior (M) : HEVC can be played via browser
8. Steps to reproduce (M) : http://www.h265files.com/embed-h265-video.php > play Embedded h265/HEVC Video
9. Screen Capture (M) : Yes
10. MORE INFORMATION (O): AT&T did quick test on some of your devices that support HEVC codec. AT&T are working on some test cases for HEVC streaming.
It's not working on Chrome browser

Please let us know Mozilla's release plan fof H.265.
When it fixed, please share Engineering Report or Release info. for patches. 


Actual results:

H.265/HEVC Streaming not working
Firefox displays the message 'No video with supported format and MIME type 


Expected results:

HEVC can be played via browser
Severity: normal → critical
OS: Unspecified → Android
Priority: -- → P1
Hardware: Unspecified → Other
Component: General → Audio/Video
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 50 Branch → Trunk
Mozilla currently has no plans to support H.265. Our focus will be on AV1.
Severity: critical → normal
Priority: P1 → P5
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
(In reply to Johnny Stenback  (:jst, jst@mozilla.com) from comment #1)
> Mozilla currently has no plans to support H.265. Our focus will be on AV1.

For some impressive VP9 results refer to https://www.twoorioles.com/eve-for-vp9
See Also: → 1314147
I understand you want to support the next generation codec AV1 but this is not an answer to your users who want support for current best codec available and widely used H.265.
x265 is an open-source implementation of H.265 / HEVC and is licensed under GPL v2 compatible with MPL 2.0 license so you can use this project to handle the hard work.
I see no reasons to ignore this feature.
The reason we won't support H265 has nothing to do with the difficulty in finding a decoder, or that a decoder source code is released under GPL. Those are trivial matters.

We will not support h265 video while its patent encumbered.

BTW, even today vp9 provides better results than H265.

> I see no reasons to ignore this feature

I suggest you research about the h265 patent pools and the licensing model in use.
From what I can see, hevc is royalty-free specifically for browsers.
http://www.hevcadvance.com/pdfnew/Software_Policy_092017.pdf
HEVC Advance is ONE patent pool, there's plenty more. MPEG LA pool is another, Technicolors etc...
All with their licensing policy.
You need to log in before you can comment on or make changes to this bug.