Last Comment Bug 1332460 - While navigating to a non-remote page (eg. about:support) RDM is not disabled
: While navigating to a non-remote page (eg. about:support) RDM is not disabled
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Responsive Design Mode (show other bugs)
: 51 Branch
: Unspecified Unspecified
-- normal (vote)
: Firefox 52
Assigned To: Nobody; OK to take it and work on it
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on: enable-rdm
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-19 13:46 PST by surentharan14
Modified: 2017-01-24 10:52 PST (History)
3 users (show)
gwimberly: needinfo? (surentharan14)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image surentharan14 2017-01-19 13:46:38 PST
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170118123726

Steps to reproduce:

step 1: Launch Firefox
step 2: Responsive Design Mode is enabled.
step 3:Navigate to a non-remote page. (Eg. about:support)	



Actual results:

The non-remote page is opened with RDM enabled.


Expected results:

The page is correctly loaded and the RDM tool is disabled.
Comment 1 User image Grover Wimberly IV [:Grover-QA] 2017-01-24 10:46:58 PST
Cannot reproduce this issue with the newest version of Nightly with the following specs: 
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Can you see into trying to reproduce this issue in the newest version of Firefox Nightly?
Comment 2 User image J. Ryan Stinnett [:jryans] (use ni?) 2017-01-24 10:52:11 PST
The appears to work correctly in the new RDM design, first enabled in 52.  It will reach release in ~6 more weeks.

Please reopen if you see this behavior is 52 or later.

Note You need to log in before you can comment on or make changes to this bug.