Crash in PLDHashTable::Search | nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget

RESOLVED FIXED in Firefox 53

Status

()

defect
--
critical
RESOLVED FIXED
2 years ago
3 months ago

People

(Reporter: alice0775, Assigned: tschneider)

Tracking

({crash, reproducible})

53 Branch
mozilla53
x86
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

Details

(crash signature)

Reporter

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-ecc58f46-53a7-4dc4-b2ca-029b22170122.
=============================================================

Reproduced: several crash while open news topics, but no definite procedure.

STR:
1. http://news.yahoo.co.jp
2. Open several topics
Reporter

Updated

2 years ago
Blocks: 1321865
Reporter

Comment 2

2 years ago
with e10s: bp-a1bb3288-0b35-4ed4-9755-65a332170122
without e10s: bp-d49e4e5a-3d86-4a55-93cd-db8392170122
Crash Signature: [@ PLDHashTable::Search | nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget] → [@ PLDHashTable::Search | nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget] [@ nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget]
Setting 'dom.IntersectionObserver.enabled = false' seems to be a workaround, so far.

Updated

2 years ago
Duplicate of this bug: 1332966

Updated

2 years ago
Crash Signature: [@ PLDHashTable::Search | nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget] [@ nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget] → [@ PLDHashTable::Search | nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget] [@ nsTHashtable<T>::Contains | mozilla::dom::DOMIntersectionObserver::UnlinkTarget] [@ PLDHashTable::Search | mozilla::dom::DOMIntersectionObs…
Bug 1321865 has been backed out and will be in tomorrow's nightlies.
Assignee: nobody → tschneider
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.