Closed Bug 1333511 Opened 4 years ago Closed 4 years ago

Port bug 1277968 - Use the executable for non-plugin child processes on Linux

Categories

(Thunderbird :: Build Config, defect)

53 Branch
Unspecified
Linux
defect
Not set
normal

Tracking

(thunderbird53 fixed, thunderbird54 fixed)

RESOLVED FIXED
Thunderbird 54.0
Tracking Status
thunderbird53 --- fixed
thunderbird54 --- fixed

People

(Reporter: aleth, Assigned: aleth)

References

Details

(Whiteboard: sb+)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1277968 +++

This is a followup for bug 1114647 — using the "firefox" executable to run content processes (instead of the confusingly named plugin-container) can't work on Linux currently because of how the sandbox code makes various things depend on each other, combined with firefox (with libmozsandbox statically linked into it, on desktop) not being able to link directly against libxul the way plugin-container can.

See bug 1268733 comment #9 for more context and an idea about how to deal with this: replace the symbol dependencies between libmozsandbox and libxul by passing appropriate pointers as part of XREChildData, and then linkage won't matter (and, as a side effect, the weak symbol hacks can go away).
Assignee: nobody → aleth
Blocks: 1277968
Status: NEW → ASSIGNED
No longer depends on: e10s-rename, 1277968, 1313808
Summary: Use the firefox executable for non-plugin child processes on Linux → Port bug 1277968 - Use the executable for non-plugin child processes on Linux
Try push to check the naive port works fine with c-c not setting MOZ_SANDBOX, and the paths to the plugin-container: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=e684380bc4cb4c05a449d56a32044b39b8441a80
(In reply to aleth [:aleth] from comment #1)
> Try push to check the naive port works fine with c-c not setting
> MOZ_SANDBOX, and the paths to the plugin-container:

sorry, I meant MOZ_CONTENT_SANDBOX of course, iirc that's not set for TB.
Comment on attachment 8830032 [details] [diff] [review]
Port bug 1277968: Use the executable for non-plugin child processes on Linux

So we make the "almost the same" "even more almost the same" ;-)

Thanks!
Attachment #8830032 - Flags: review?(jorgk) → review+
Try looks OK (compared with c-c).
Attachment #8830032 - Flags: review?(clokep) → review+
https://hg.mozilla.org/comm-central/rev/60e4648f97111ce2d5cc2fd46b49c00fdfeda06a
Bug 1333511 - Port bug 1277968: Use the executable for non-plugin child processes on Linux. r=jorgk,clokep
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 54.0
Comment on attachment 8830032 [details] [diff] [review]
Port bug 1277968: Use the executable for non-plugin child processes on Linux

[Approval Request Comment]
Regression caused by (bug #): Blocking bug landed on 53
User impact if declined: possible Linux child process issues
Testing completed (on c-c, etc.): green(ish) try
Risk to taking this patch (and alternatives if risky): low
Attachment #8830032 - Flags: approval-comm-aurora?
Attachment #8830032 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.