Closed Bug 1333792 Opened 4 years ago Closed 3 years ago

Try push confirmation emails for Taskcluster jobs should link to the Task inspector rather than the upload directory on archive.m.o

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task, P5)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: yzen, Assigned: aselagea)

References

Details

Attachments

(1 file)

Try push confirmation emails for Taskcluster jobs should link to the Task inspector (eg: https://tools.taskcluster.net/task-inspector/#dQgubLeiQpCXvv1QSHmjIg/0) rather than the upload directory on archive.m.o

This is a similar list is available on Treeherder on the "job details" tab.

As per emorley:
The system that sends those emails was very much written when the jobs were scheduled only by buildbot and not also by taskcluster

There are cases when archive.m.o link 404's or points to an empty dir (see  https://archive.mozilla.org/pub/firefox/try-builds/yura.zenevich@gmail.com-56606f67ed8f03fe7053326f4186286d43746a99/ and https://treeherder.mozilla.org/#/jobs?repo=try&revision=56606f67ed8f03fe7053326f4186286d43746a99&filter-searchStr=Windows%202012%20x64%20opt%20Executed%20by%20TaskCluster%20build-win64%2Fopt%20tc(B)&selectedJob=71367013)

Relevant code:
https://dxr.mozilla.org/build-central/source/buildbotcustom/bin/try_mailer.py
Component: General Automation → Buildduty
QA Contact: catlee → bugspam.Callek
I'd like to help with this, but I'd need some suggestions/hints:

From what I can see, the messages that are emailed when submitting a push to the try server come from here: https://dxr.mozilla.org/build-central/source/buildbotcustom/status/generators.py#15-38
It looks to me that we should also add the link to the Task inspector here, but I'm not sure how to retrieve that.

Also, is there a way to test the solution?

ni-ing :emorley here since I noticed that he worked on this in the past and maybe he can provide some help.

Thanks!
Flags: needinfo?(emorley)
Assignee: nobody → aselagea
I haven't pushed to try for several years, so this is from memory - but I think there are two types of emails:
1) The initial confirmation email (generated by the code linked in comment 1)
2) The failure/success on completion email (generated by https://dxr.mozilla.org/build-central/source/buildbotcustom/bin/try_mailer.py)

I don't know enough about buildbot/taskcluster to know what's best here, but I would imagine the options are:
a) For taskcluster jobs, just don't link to the archive.m.o location at all, and direct people to Treeherder (the link to is already in the email) - where they can either use the "task inspector" link, or else switch to the "job details" tab which displays the list of artifacts similar to the task inspector
b) For taskcluster jobs, add a link to the task inspector directly (but this requires that the task_id be accessible during email generation - I have no idea whether it is)

It would seem (b) is the preferred solution, but someone from release engineering who worked on the buildbot-taskcluster bridge would have to explain how to get the taskcluster task_id during email generation.

Hope that helps!
Flags: needinfo?(emorley)
I don't think the task_id is available to buildbot here. The two systems aren't communicating at the time when we're creating this email message.

An alternate option would be to link to the index artifact browser, which we could reference by revision. I don't know if incomplete tasks appear there though.
Priority: -- → P3
Note explaining the priority level: P5 doesn't mean we've lowered the priority, but the contrary. However, we're aligning these levels to the buildduty quarterly deliverables, where P1-P3 are taken by our daily waterline KTLO operational tasks.
Priority: P3 → P5
tryserver emails point to treeherder and archive.m.o. The latter is a lie now that all ff platforms are in TC.

Given that, should we remove the reference to archive.m.o from the message[0] and instead reiterate that artifacts can be found through the Treeherder URL and, in Taskcluster cases, also in the artifact index?
Attachment #8908307 - Flags: review?(mtabara)
Attachment #8908307 - Flags: review?(aselagea)
Comment on attachment 8908307 [details] [diff] [review]
170914_bug_1333792_try_email_archive-bbotcustom.patch

Sounds good to me.
Attachment #8908307 - Flags: review?(mtabara) → review+
Comment on attachment 8908307 [details] [diff] [review]
170914_bug_1333792_try_email_archive-bbotcustom.patch

Yeah, that makes sense. We shouldn't point users to look for builds and logs in archive.m.o. since they're no longer there.
Attachment #8908307 - Flags: review?(aselagea) → review+
https://hg.mozilla.org/build/buildbotcustom/rev/994ad65b2abdbdb881cd6874d102d50d8a3d75e3
Bug 1333792 - Try push confirmation emails for Taskcluster jobs should link to the Task inspector rather than the upload directory on archive.m.o, r=mtabara
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
I think we're good here. Here's the mail received for one of my latest try pushes:

"
Thank you for your try submission. It's the best!

Results will be displayed on Treeherder as they come in:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4e08923b4dac7c47a959f68d93257a97ac400cda

Once completed, all build and log artifacts will be available through the Treeherder URL above.

All Taskcluster based artifacts can also be found in the Taskcluster Artifact Index:
e.g.  https://tools.taskcluster.net/index/artifacts/gecko.v2.try.revision.4e08923b4dac7c47a959f68d93257a97ac400cda

Summary:
  * try: -b do -p win32,win64,linux64,linux -u
  * Bug 1397829 - add buildernames for stylo-disabled tests which run on hardware, win7 and win10
"
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.