Upon upgrading to Firefox 51 and trying the WebGL 2 demo "After the Flood", upon the progress bar hitting 100% Firefox will force quit every time

RESOLVED DUPLICATE of bug 1333534

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1333534
2 years ago
2 years ago

People

(Reporter: me, Unassigned)

Tracking

({crash})

51 Branch
x86_64
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], )

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.95 Safari/537.36

Steps to reproduce:

Running on macOS 10.12.2 on Macbook Pro (Retina, 15-inch, Late 2013)
(Graphics: NVIDIA GeForce GT 750M 2048 MB)

- Upgraded to Firefox 51.0 64-bit (Public Production version)
- Went to the following page:https://playcanv.as/e/p/44MRmJRU/


Actual results:

- Page loads and then progress bar fills to 100%
- Firefox force quits each time with no error indication


Expected results:

- "After the Flood" WebGL 2 demo should have loaded
Reporter

Updated

2 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Reporter

Comment 1

2 years ago
I also tried refreshing Firefox, which made no difference, and then I tried creating a brand new profile and trying the url in that.  With the brand new profile instead of Firefox force quitting, the tab simply crashes and shows a crash report dialog
Reporter

Comment 2

2 years ago
I also tried with a brand new profile within the Firefox Nightly build 54.0a1 (2017-01-25) (64-bit) and again the tab simply crashes and shows a crash report dialog
Reporter

Comment 3

2 years ago
about:support information from Nightly: 

{
  "application": {
    "name": "Firefox",
    "osVersion": "Darwin 16.3.0",
    "version": "54.0a1",
    "buildID": "20170125030214",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0",
    "safeMode": false,
    "updateChannel": "nightly",
    "supportURL": "https://support.mozilla.org/1/firefox/54.0a1/Darwin/en-US/",
    "numTotalWindows": 1,
    "numRemoteWindows": 1,
    "remoteAutoStart": true,
    "autoStartStatus": 1
  },
  "modifiedPreferences": {
    "browser.cache.frecency_experiment": 2,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.filesystem_reported": 1,
    "browser.download.importedFromSqlite": true,
    "browser.places.smartBookmarksVersion": 8,
    "browser.startup.homepage_override.buildID": "20170125030214",
    "browser.startup.homepage_override.mstone": "54.0a1",
    "browser.tabs.crashReporting.includeURL": true,
    "browser.urlbar.lastSuggestionsPromptDate": 20170125,
    "browser.urlbar.daysBeforeHidingSuggestionsPrompt": 3,
    "dom.gamepad.extensions.enabled": true,
    "extensions.lastAppVersion": "54.0a1",
    "media.gmp-manager.buildID": "20170125030214",
    "media.gmp.storage.version.observed": 1,
    "media.gmp-gmpopenh264.lastUpdate": 1485400171,
    "media.gmp-gmpopenh264.version": "1.6",
    "media.gmp-gmpopenh264.abi": "x86_64-gcc3",
    "media.gmp-manager.lastCheck": 1485400171,
    "media.gmp-widevinecdm.version": "1.4.8.903",
    "media.gmp-widevinecdm.lastUpdate": 1485400172,
    "media.gmp-widevinecdm.abi": "x86_64-gcc3",
    "network.cookie.prefsMigrated": true,
    "network.predictor.cleaned-up": true,
    "places.history.expiration.transient_current_max_pages": 122334,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "security.sandbox.content.tempDirSuffix": "{11fcb8ca-cbe5-7949-9e36-4e6209bb073f}"
  },
  "lockedPreferences": {},
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": false,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.13.1",
      "version": "4.13.1"
    },
    "NSS": {
      "minVersion": "3.29 Beta",
      "version": "3.29 Beta"
    },
    "NSSUTIL": {
      "minVersion": "3.29 Beta",
      "version": "3.29 Beta"
    },
    "NSSSSL": {
      "minVersion": "3.29 Beta",
      "version": "3.29 Beta"
    },
    "NSSSMIME": {
      "minVersion": "3.29 Beta",
      "version": "3.29 Beta"
    }
  },
  "userJS": {
    "exists": false
  },
  "crashes": {
    "submitted": [
      {
        "id": "bp-8667baa0-27ff-48a8-8737-809f02170126",
        "date": 1485400176000,
        "pending": false
      },
      {
        "id": "bp-06dbb439-ca9e-4515-8f12-6cc152170126",
        "date": 1485399878000,
        "pending": false
      },
      {
        "id": "bp-510a5a90-defa-40d5-a0e7-89e6b2170126",
        "date": 1485399543000,
        "pending": false
      },
      {
        "id": "bp-6d47af1b-6115-4fd7-93a1-952672170126",
        "date": 1485399528000,
        "pending": false
      }
    ],
    "pending": 0
  },
  "sandbox": {
    "contentSandboxLevel": 2
  },
  "experiments": [],
  "extensions": [
    {
      "name": "Application Update Service Helper",
      "version": "1.0",
      "isActive": true,
      "id": "aushelper@mozilla.org"
    },
    {
      "name": "FlyWeb",
      "version": "1.0.0",
      "isActive": true,
      "id": "flyweb@mozilla.org"
    },
    {
      "name": "Form Autofill",
      "version": "1.0",
      "isActive": true,
      "id": "formautofill@mozilla.org"
    },
    {
      "name": "Multi-process staged rollout",
      "version": "1.7",
      "isActive": true,
      "id": "e10srollout@mozilla.org"
    },
    {
      "name": "Pocket",
      "version": "1.0.5",
      "isActive": true,
      "id": "firefox@getpocket.com"
    },
    {
      "name": "Presentation",
      "version": "1.0.0",
      "isActive": true,
      "id": "presentation@mozilla.org"
    },
    {
      "name": "SHA-1 deprecation staged rollout",
      "version": "1.0",
      "isActive": true,
      "id": "disableSHA1rollout@mozilla.org"
    },
    {
      "name": "Shield Recipe Client",
      "version": "1.0.0",
      "isActive": true,
      "id": "shield-recipe-client@mozilla.org"
    },
    {
      "name": "Web Compat",
      "version": "1.0",
      "isActive": true,
      "id": "webcompat@mozilla.org"
    },
    {
      "name": "WebCompat Reporter",
      "version": "1.0.0",
      "isActive": true,
      "id": "webcompat-reporter@mozilla.org"
    },
    {
      "name": null,
      "version": "1.2.X",
      "isActive": false,
      "id": "motive_accessibility@motive.com"
    }
  ],
  "graphics": {
    "numTotalWindows": 2,
    "numAcceleratedWindows": 2,
    "windowLayerManagerType": "OpenGL",
    "windowLayerManagerRemote": true,
    "supportsHardwareH264": "No",
    "currentAudioBackend": "audiounit",
    "adapterDescription": "",
    "adapterVendorID": "0x10de",
    "adapterDeviceID": "0x0fe9",
    "adapterRAM": "",
    "adapterDrivers": "",
    "driverVersion": "",
    "driverDate": "",
    "webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine",
    "webgl2Renderer": "NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureCanvasAccelerated": 1,
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "skia",
      "ApzWheelInput": 1,
      "ApzDragInput": 1,
      "TileHeight": 512,
      "TileWidth": 512
    },
    "featureLog": {
      "features": [
        {
          "name": "HW_COMPOSITING",
          "description": "Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        },
        {
          "name": "OPENGL_COMPOSITING",
          "description": "OpenGL Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        }
      ],
      "fallbacks": []
    },
    "crashGuards": []
  }
}
Reporter

Comment 4

2 years ago
Unrelated but thought I would add, if I use latest Google Chrome Canary Version 58.0.2992.0 (Official Build) canary (64-bit) which has WebGL 2 support, the page loads fine, so I don't believe it is related to my graphics drivers
I ran it on OSX 10.11.6 in a same model of Macbook pro and it does crash the tab.

And this demo crashes in both 51 and nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Keywords: crash
Whiteboard: [gfx-noted]
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333534
You need to log in before you can comment on or make changes to this bug.