Closed Bug 1333534 Opened 3 years ago Closed 1 year ago

Crash in GeForceGLDriver@0x502f61 with a webgl2 demo

Categories

(Core :: Canvas: WebGL, defect, P3)

Unspecified
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox51 --- affected
firefox52 --- wontfix
firefox53 --- affected
firefox54 --- affected

People

(Reporter: ehsan, Assigned: jgilbert)

References

()

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-3330eb7b-8e4d-4a7b-ae36-b78e62170124.
=============================================================

STR:

Using the latest Nighly on OS X 10.12.2, load https://playcanv.as/e/p/44MRmJRU/.

100% reproducible, examples of other similar crashes:
bp-a698721f-b151-4600-94e9-4be362170124
bp-0e381c71-1d69-421d-bfe0-f6c622170124
bp-c962e4d4-cc46-44de-98b3-8137f2170124
Duplicate of this bug: 1333547
Very similar crashes on 51 (release) and Aurora (I didn't try Beta, but most likely it's also affected).
Seems to be late-2013 MBP retinas with the NV 750m.
Looks like glGenerateMipmap+glFinish is having an issue. I need to try this without OSX-GL's multithreading flag to see if that's bugged on this driver.

IIRC this is a deref of 0x40, so it's not particularly concerning outside of it being a DOS, and crashing those users without e10s.
Assignee: nobody → jgilbert
The 0x40 crash address seems to be consistent, so yeah this is just a DOS vector.
Crash Signature: [@ GeForceGLDriver@0x502f61] → [@ GeForceGLDriver@0x502f61] [@ GeForceGLDriver@0x514253]
Duplicated bug 1334002 has a crash with NV 650, and there are a few other device IDs.
Whiteboard: [gfx-noted]
Duplicate of this bug: 1334004
Poking around more, we're now crashing in DrawElements as well.
Commenting out that, we're crashing in TexImage2D.
I believe we should blocklist these devices for the time being, and get in contact with Apple to decipher what's causing the crash, instead of trying to diagnose what bad state we're in ourselves.
(In reply to Jeff Gilbert [:jgilbert] from comment #8)
> Poking around more, we're now crashing in DrawElements as well.
> Commenting out that, we're crashing in TexImage2D.
> I believe we should blocklist these devices for the time being, and get in
> contact with Apple to decipher what's causing the crash, instead of trying
> to diagnose what bad state we're in ourselves.

Have we done this in code, do we need a downloadable blocklist entry for it?
Flags: needinfo?(jgilbert)
Too late for firefox 52, mass-wontfix.

Probably fixed by the macOS 10.13 update.

I see low crash volume, only OS X 10.11 and one crash on 10.12. Nothing reporting for 10.13+.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jgilbert)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.