[e10s] selectbox onfocus="this.blur();" strange incompatibility

RESOLVED FIXED in Firefox 54

Status

()

P2
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ilisepe1, Assigned: enndeakin)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

50 Branch
mozilla54
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox54 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160106234723

Steps to reproduce:

<select name="foo" onfocus="this.blur();"><option>1</option><option>2</option></select>



Actual results:

With firefox ver <50 the user won't be able to open the select box.

With firefox ver >50 (51 for sure) the user can expand the select box and select anything. This happens *only* with windows 7 or 10. With windows XP or linux (ubuntu 14.04) the user can't open it.


Expected results:

The user should not be able to open the select box. That's what was happening since firefox version 2.

Updated

2 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core

Comment 1

2 years ago
It happens only with multiprocess enabled. I think it's a dupe of bug 910022.
Blocks: 1154677
Summary: selectbox onfocus="this.blur();" strange incompatibility → [e10s] selectbox onfocus="this.blur();" strange incompatibility
Whiteboard: DUPEME
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME
(Reporter)

Comment 2

2 years ago
I can confirm that disabling multiprocess solves the problem.

Disabling was tricky though.
I ended up trying some of the following solutions:
about:config -> browser.tabs.remote.autostart set false
about:config -> browser.tabs.remote.autostart.2 set false (or delete)

and then restart firefox
about:support -> check that Multiprocess Windows is 0/1

Apart from that I think that you need to fix this bug so firefox is consistent with this onfocus="this.blur()" feature! Some people may use this feature for restricting access to their web apps...
I vote for major.
(Reporter)

Updated

2 years ago
Severity: normal → major
(Reporter)

Updated

2 years ago
Priority: -- → P2
(Reporter)

Comment 3

2 years ago
Any news?
(Assignee)

Comment 4

2 years ago
Created attachment 8834898 [details] [diff] [review]
Hide popup on blur

I also moved the event listeners to the system group.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #8834898 - Flags: review?(jaws)
Comment on attachment 8834898 [details] [diff] [review]
Hide popup on blur

Review of attachment 8834898 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/test/general/browser_selectpopup.js
@@ +795,5 @@
>    yield hideSelectPopup(selectPopup, "escape");
>    yield BrowserTestUtils.removeTab(tab);
>  });
> +
> +// This test checks that the popup is closed when the select element is blurred. 

note, the trailing space here will fail eslint.
Attachment #8834898 - Flags: review?(jaws) → review+
This will need to be rebased as I just landed bug 1336125 and bug 1336301 on autoland.

Comment 7

2 years ago
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3bf536f5b98
close popup when select element is blurred, r=jaws

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f3bf536f5b98
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54

Updated

2 years ago
Depends on: 1352817
Since the patch pushed for this bug also contains an automated test, I don't think manual testing would be of much value here.

Neil, if you think Manual QA should instead be looking at this, feel free to flip the qe-verify flag or ni? me directly.
Flags: qe-verify-

Updated

2 years ago
Duplicate of this bug: 1327929
You need to log in before you can comment on or make changes to this bug.