Closed Bug 1334179 Opened 3 years ago Closed 3 years ago

Figure out a touch-friendly UX for entering/exiting fullscreen mode

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1328269

People

(Reporter: kats, Unassigned)

References

(Blocks 2 open bugs)

Details

This is a spinoff from https://bugzilla.mozilla.org/show_bug.cgi?id=1322349. When a user is in fullscreen mode, they can move the mouse to the top of the screen to temporarily make the URL bar/toolbar visible. Moving the mouse back down makes it hidden again. This works fine if you have a mouse, but on touch-enabled Windows tablets for example there might not be a mouse.

Instead, we should provide some touch-equivalent for doing this, and for exiting fullscreen mode entirely. Right now the user can do a tap or (once bug 1322349 lands) a swipe at the top edge of the screen to show the toolbar, but dismissing it again (the way you can by moving the mouse down) is not obvious.

Also, I've only tested this behaviour on a Surface Pro and it may not work uniformly across all Windows touch devices, particularly ones with narrower or missing touch-sensitive bezels.

We should spend some time figuring out a good UX for this and make the necessary changes.
When having several tabs opened, swiping downwards at the top of the screen may open the tab from where the swipe happens in a new window.
I'm going to dupe this to bug 1328269 which was filed earlier for basically the same issue, and is a more concrete user-reported bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1328269
You need to log in before you can comment on or make changes to this bug.