RFE: "Open this link" in right-click menu (command to force a link to open in the same window, like in Netscape 3)

RESOLVED DUPLICATE of bug 70990

Status

--
enhancement
RESOLVED DUPLICATE of bug 70990
17 years ago
10 years ago

People

(Reporter: andrixnet, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 95
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Workarounds in comment #8)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Netscape 3 had another neat function : 

whenever user right-clicks on a link, in the menu appears, among others : 

"Open this link (URL)" which forces the link under the cursor to be opened in
the current browser window.

This ignores TARGET attribute in <A> tag.
Feature is usefull when browsing frame based sites with multiple windows.
Example : using Yahoo mail or Yahoo clubs, in the web interface of these pages,
some links have target attribute set to work correctly with the frame based
interface. 
However : from the original window, open a link in a new window. 
In this new window, if one follows another link in that page, the page is opened
in the previous browser window, in one of it's frames.
In my current window nothing happens and in the original frame based window, a
frame is substituted with a new one (something I might not want, since in that
window I may have navigated in a different direction). 

In Netscape 3 (feature was lost in Netscape 4) I had the option to make sure I
continue in this window (maybe I don't want a new window, maybe   there are too
many already) by right-clik on a link and select "Open this link".

Mozilla does not have this functionality. 



Reproducible: Always
Steps to Reproduce:
1. have a page displayed
2. right-click on a link
3. If this link specifies a TARGET attribute there is no way to force Mozilla to
follow that link the the same browser window. (consider a new tab same as a new
window in this case).


Actual Results:  Cannot follow a link in current window if TARGET is set and
another windo contains the frame that target points to.

Expected Results:  Be able to control where you want a link displayed. Current
window, or new window (consider tabs as new window)

See Netscape 3 behaviour.

Comment 1

17 years ago
Tried with 1st framed site that came to mind, http://www.ditl.org/

I don't have a right click menu  item called "Open this link (URL)" for any of
the links. Screen shot attached.

2002031104, Win2K

Comment 2

17 years ago
Created attachment 76207 [details]
screen shot

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 64749 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
On comment #3: bug 64749 is marked exclusively for MAC. Request is for PC also.

Updated

16 years ago
Component: User Interface Design → Browser-General

Comment 5

16 years ago
Ok.

See also bug 78037, pref to make links always open in the same window when you
left-click them.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

16 years ago
->XPApps

See comment #4 in bug 64749

Assignee: mpt → blaker
Component: Browser-General → XP Apps: GUI Features
QA Contact: zach → paw

Updated

16 years ago
Keywords: 4xp
Setting as new and modifying title to reflect the fact that it is a RFE.

eRmoving 4xp keyword since NS4 did not have this feature.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
Summary: "Open this link" option in right-click menu (like Netscape 3) → RFE:"Open this link" option in right-click menu (like Netscape 3)
Product: Core → Mozilla Application Suite

Comment 8

14 years ago
A few workarounds:

* In about:config, change browser.block.target_new_window to true (backend pref
is already implemented by Bug 78037)
* Drag the link out of the content frame then drop it back.
* Drop it on the Go menu.
* Drop it on the title of the current tab.

Prog.
Depends on: 78037
Summary: RFE:"Open this link" option in right-click menu (like Netscape 3) → RFE: "Open this link" option in right-click menu (option to force links to open in the same window, like Netscape 3)
Whiteboard: Workarounds in comment #8

Updated

14 years ago
Summary: RFE: "Open this link" option in right-click menu (option to force links to open in the same window, like Netscape 3) → RFE: "Open this link" in right-click menu (command to force a link to open in the same window, like in Netscape 3)

Updated

14 years ago
Blocks: 86194

Comment 9

14 years ago

*** This bug has been marked as a duplicate of 70990 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.