Firefox 54.0a1 (2017-01-29) crashes in [@ mozilla::dom::IdleRequest::IdleRun ]

VERIFIED FIXED in Firefox 54

Status

()

--
critical
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: Virtual, Assigned: farre)

Tracking

(6 keywords)

54 Branch
mozilla54
crash, crashreportid, nightly-community, regression, reproducible, topcrash
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 unaffected, firefox54+ verified)

Details

(crash signature, URL)

Attachments

(1 attachment)

STR:
1. Open this URL - https://myanimelist.net/
2. Enjoy the crash
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: crash, crashreportid
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox-esr45: --- → unaffected
This is currently the top crash on Nightly, with 61% of all crashes on Windows for the latest Nightly.

Comment 4

2 years ago
I have this crash at Youtube but only using the experimental Material Design UI [1].
I don't know, however, how to forcefully apply the UI. The tutorial in [1] does not work.

[1]: http://www.androidpolice.com/2016/04/30/youtube-is-testing-a-new-material-ui-on-the-web/
I get this crash a second or two after I open a page at the Atlantic Monthly, such as:
  https://www.theatlantic.com/politics/archive/2017/01/trumps-very-successful-start-to-a-presidency/514223/

Comment 6

2 years ago
backoutbugherder
Nightly respins are running on mozilla-central.
https://hg.mozilla.org/mozilla-central/rev/71224049c0b5
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54

Updated

2 years ago
See Also: → bug 1334913
Crash Signature: [@ mozilla::dom::IdleRequest::IdleRun ] → [@ mozilla::dom::IdleRequest::IdleRun ] [@ mozilla::dom::CallbackObject::CallSetup::CallSetup]
Duplicate of this bug: 1334913
(Assignee)

Comment 8

2 years ago
Created attachment 8831688 [details] [diff] [review]
0001-Bug-1334904-Add-test-for-when-rIC-timeouts-doesn-t-n.patch

Created a test for the crash.
Assignee: nobody → afarre
Flags: needinfo?(afarre)
Attachment #8831688 - Flags: review?(bkelly)
Attachment #8831688 - Flags: review?(bkelly) → review+
tracking-firefox54: ? → +

Comment 9

2 years ago
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/531b72b93b87
Add test for when rIC timeouts doesn't need timeout. r=bkelly
No crashes since Firefox 54.0a1 (2017-01-29) with [@ mozilla::dom::IdleRequest::IdleRun ] signature,
so I'm marking this as VERIFIED.
Status: RESOLVED → VERIFIED
status-firefox54: fixed → verified
You need to log in before you can comment on or make changes to this bug.