Closed Bug 1334956 Opened 3 years ago Closed 3 years ago

devtools/client/framework/options-panel.css uses float: inline-start, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 6th

Categories

(DevTools :: Framework, defect)

53 Branch
defect
Not set

Tracking

(firefox-esr45 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53+ fixed, firefox54 fixed)

RESOLVED FIXED
Firefox 54
Tracking Status
firefox-esr45 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 + fixed
firefox54 --- fixed

People

(Reporter: philor, Assigned: tomer)

References

Details

Attachments

(1 file)

inline-start as a value for float is behind the pref layout.css.float-logical-values.enabled, which is still disabled on beta_or_release, so https://hg.mozilla.org/releases/mozilla-aurora/annotate/d859e69475796f76214f07c6d133c3a1f325156c/devtools/client/framework/options-panel.css#l18 is going to cause browser_parsable_css.js to be permaorange when 53 merges to beta on 2017-03-07.

Oh, and it also will stop working.

[Tracking Requested - why for this release]: permanently failing tests on merge to mozilla-beta
Merge the 6th, release the 7th.
Summary: devtools/client/framework/options-panel.css uses float: inline-start, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 7th → devtools/client/framework/options-panel.css uses float: inline-start, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 6th
Assignee: nobody → tomer.moz.bugs
Status: NEW → ASSIGNED
Comment on attachment 8831671 [details]
Bug 1334956 - devtools/client/framework/options-panel.css uses float: inline-start

This should fix beta, unless you prefer to backout the change instead.
Attachment #8831671 - Flags: review?(jryans)
See Also: → 1335010
Comment on attachment 8831671 [details]
Bug 1334956 - devtools/client/framework/options-panel.css uses float: inline-start

https://reviewboard.mozilla.org/r/108214/#review109300

Thanks, didn't realize it was preffed off for certain channels.
Attachment #8831671 - Flags: review?(jryans) → review+
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #4)
> Thanks, didn't realize it was preffed off for certain channels.
Me as well. This is very difficult to debug when it is preffed on on your dev environment but not on production, and I am not sure if nightly tests could catch automatically.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/33a7ad19a335
devtools/client/framework/options-panel.css uses float: inline-start r=jryans
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/33a7ad19a335
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Please request Aurora approval on this at your earliest convenience :)
Flags: needinfo?(tomer.moz.bugs)
Comment on attachment 8831671 [details]
Bug 1334956 - devtools/client/framework/options-panel.css uses float: inline-start

Approval Request Comment
[Feature/Bug causing the regression]: bug 1335010
[User impact if declined]: test failures
[Is this code covered by automated tests?]: no, but it cause failures due to unimplemented keywords.  
[Has the fix been verified in Nightly?]: yes.
[Needs manual test from QE? If yes, steps to reproduce]: probably not
[List of other uplifts needed for the feature/fix]: no dependencies beside bug 1335010 which this patch fix.
[Is the change risky?]: not too much.
[Why is the change risky/not risky?]: Just backporting CSS code to use :dir().
[String changes made/needed]:
Flags: needinfo?(tomer.moz.bugs)
Attachment #8831671 - Flags: approval-mozilla-aurora?
Please ignore my previous comment, as I've mentioned the wrong bug. I'm Sorry for the inconvenience. 

Approval Request Comment
[Feature/Bug causing the regression]: bug 1323504
[User impact if declined]: test failures
[Is this code covered by automated tests?]: no, but it cause failures due to unimplemented keywords.  
[Has the fix been verified in Nightly?]: yes.
[Needs manual test from QE? If yes, steps to reproduce]: probably not
[List of other uplifts needed for the feature/fix]: no dependencies beside bug 1323504 which this patch fix.
[Is the change risky?]: not too much.
[Why is the change risky/not risky?]: Just backporting CSS code to use :dir().
[String changes made/needed]:
Comment on attachment 8831671 [details]
Bug 1334956 - devtools/client/framework/options-panel.css uses float: inline-start

Fix test failures. Aurora53+.
Attachment #8831671 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Track 53+ as this will happen when merging to mozilla-beta.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.