Closed Bug 1335108 Opened 5 years ago Closed 5 years ago

Preferences text does not match behavior for browser.ctrlTab.previews

Categories

(Firefox :: Tabbed Browser, enhancement)

53 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jibbers42, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170130084100

Steps to reproduce:

Open Preferences
Enable: Ctrl+Tab cycles through tabs in recently used order
Open 3 or more tabs
Use Ctrl+Tab to cycle tabs


Actual results:

Tab order is correct, but a new tab preview is shown during switching instead of an immediate tab switch as before.


Expected results:

The tab order should still be correct, but visual cycling behavior should be the same whether the feature is on or off.

In other words the tab order and the tab preview during switching are completely orthogonal. It seems there used to be a browser.ctrlTab.mostRecentlyUsed, but it was replaced by browser.ctrlTab.previews (see #608298).

This doesn't make sense, they are two different things and both settings should be available for their respective purposes.

* browser.ctrlTab.mostRecentlyUsed - this should control tab order
* browser.ctrlTab.previews - this should control preview or immediate switch

Any combination of the two settings is valid; one does not subsume the other.
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID 	20170130030205

The issue is reproducible on the latest Firefox release (51.0.1) and on the latest Nightly (54.0a1). 
On a personal note I think it's actually very helpful to have a preview of your tabs in order to see what you're switching to.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
Dão, do we still have 2 prefs and/or how hard is it to disentangle this?
Blocks: 1116787
Flags: needinfo?(dao+bmo)
(In reply to :Gijs from comment #2)
> Dão, do we still have 2 prefs

No.

> and/or how hard is it to disentangle this?

We don't intend to do so. Without previews, switching in recently used order between more than two tabs would be unusable. And without the recently used order, there's no point in having previews, as the order matches the tab strip and is easily predictable.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dao+bmo)
Resolution: --- → WONTFIX
How is it "unusable"? I've been doing it for years with the Ctrl-Tab add-on. WOW, IT'S YOUR ADD-ON Dão!! Now I'm really confused.

Frankly I can't remember if Ctrl+Tab add-on did an immediate tab switch or simply highlighted the tabs in some way, but it was very usable either way.

1) If just a tab highlight, you at least are looking where the info you want is known to be, the thumbnails are a different representation with no memory association.
2) If immediate switch, seeing the full tab instead of some worthless little thumbnail would be much more "usable". This also has the benefits of 1) above.

I'm not still not sure exactly why not do one of the above when in recently used order (whatever Ctrl-Tab did), just like in standard order - and let people show thumbnails if they want.

Again, completely orthogonal.

I can say for sure as someone with moderate visual disability, Ctrl-Tab was better.
(In reply to jibbers42 from comment #4)
> How is it "unusable"? I've been doing it for years with the Ctrl-Tab add-on.
> WOW, IT'S YOUR ADD-ON Dão!! Now I'm really confused.
> 
> Frankly I can't remember if Ctrl+Tab add-on did an immediate tab switch or
> simply highlighted the tabs in some way, but it was very usable either way.

The add-on did neither of these things as far as I remember...
I think you are right and I just got used to it since I wanted recently used switching so badly :)

Anyway, I still feel the experience would be better with one of the two behaviors mentioned above and this issue shouldn't be closed. The issues really are entangled.
> Without previews, switching in recently used order between more than two tabs would be unusable

Why it would? I do it this way for all these years without any problem (with the help of TMP).

When you hold ctrl, and click "tab", every time it switches to the actual tab and you can directly tell what the content is, in full screen, and decide if it's the tab you want. If it yes, you release the ctrl; otherwise you tap Tab again.

It is much easier than the small previews which is super hard to tell which tab it actually is.

Can I get some rationale behind this removal, and why you would think that's "unusable"?
Flags: needinfo?(dao+bmo)
Duplicate of this bug: 1428565
> Without previews, switching in recently used order between more than two tabs would be unusable.

It's extremely common to use ctrl+tab to switch between two tabs that are not adjacent on the tab bar. There is no need to look at a preview to know which tab will be shown. Ctrl+tab shows the last selected tab. Ctrl+tab+tab gives the one before that. I understand you personally don't use this, but others do. I content it doesn't make sense to change tab behavior based on whether previews are shown. That said, I have had to just live with previews enables and tab switching doesn't seem to be slowed.
(In reply to fireattack from comment #7)
> > Without previews, switching in recently used order between more than two tabs would be unusable
> 
> Why it would? I do it this way for all these years without any problem (with
> the help of TMP).
> 
> When you hold ctrl, and click "tab", every time it switches to the actual
> tab and you can directly tell what the content is, in full screen, and
> decide if it's the tab you want. If it yes, you release the ctrl; otherwise
> you tap Tab again.
> 
> It is much easier than the small previews which is super hard to tell which
> tab it actually is.
> 
> Can I get some rationale behind this removal, and why you would think that's
> "unusable"?

There was no removal, we just changed the pref name at some point. We had never implemented TMP's behavior.

I guess it wouldn't be unusable, but temporarily switching the whole content area can feel a bit overwhelming and confusing. Some kind of preview UI (as every major OS has it for Alt+Tab) makes it clearer that you're in a special mode. It allows you to look ahead in the most recently used tabs list. It also leaves more room for tab titles, and avoids scrolling back and forth when the tabs you're previewing are spread across an overflowing tab strip.
Flags: needinfo?(dao+bmo)
(In reply to Dão Gottwald [::dao] from comment #10)

> I guess it wouldn't be unusable, but temporarily switching the whole content
> area can feel a bit overwhelming and confusing. Some kind of preview UI (as
> every major OS has it for Alt+Tab) makes it clearer that you're in a special
> mode. It allows you to look ahead in the most recently used tabs list. It
> also leaves more room for tab titles, and avoids scrolling back and forth
> when the tabs you're previewing are spread across an overflowing tab strip.

We don't really need to justify for each other; everyone has its own preference. You prefer to have a preview, that's fine; I (among others in this threads) prefer to switch directly without preview. I can also write paragraphs why that's better (*for me*), but again, just preference.

What we asked is to un-tie the option of "ctrl-tab using recent visited order" and "ctrl-tab having preview or not". It doesn't make sense to tie them together because people may prefer to have one but not the other. I don't think such request is unreasonable. I'm very grateful that Firefox offers such option for customizing ctrl+tab to begin with (which Chrome doesn't have one at all), but tying these two unrelated things together hurts its usability.

> There was no removal, we just changed the pref name at some point. We had
> never implemented TMP's behavior.

I must be confused by what Gijs implied (see below), sorry about that. But then please consider this as a feature request, especially considering now no extension can (like the old TMP) help us any more.
> Dão, do we still have 2 prefs and/or how hard is it to disentangle this?

Cheers.
It's not so much that your request is necessarily unreasonable, but I don't think you represent a large enough user base to justify implementing and maintaining the requested behavior. We have limited resources.
How do you know that lol? Of course there is no "large enough user base" if they literally can't try it.
(In reply to fireattack from comment #13)
> How do you know that lol?

That's my estimation based on established Alt+Tab behavior for instance.

> Of course there is no "large enough user base" if
> they literally can't try it.

In general we don't add features speculatively that we don't believe in.
You need to log in before you can comment on or make changes to this bug.