Expose preference for having Ctrl+Tab cycle through tabs in recently used order

VERIFIED FIXED in Firefox 50

Status

()

Firefox
Preferences
--
enhancement
VERIFIED FIXED
3 years ago
5 months ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Blocks: 1 bug, {user-doc-needed})

Trunk
Firefox 50
user-doc-needed
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 verified, relnote-firefox 50+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Created attachment 8542989 [details] [diff] [review]
patch

A Ctrl+Tab panel for switching tabs in recently used order was implemented long ago but hasn't been enabled by default for fear of breaking users' habits, although Ctrl+PageUp / Ctrl+PageDown exist as an alternative.

While enabling this by default might still be controversial (I'm not sure), allowing users to opt in to this behavior should be a good first step.

Note that bug 1063625 was filed for reducing clutter in the tabs section.
(Assignee)

Comment 1

3 years ago
Created attachment 8542990 [details]
screenshot
Attachment #8542990 - Flags: ui-review?(ux-review)

Comment 2

3 years ago
It gets enabled if you enable browser.ctrlTab.previews in about:config. I feel like that is a bug because I only want to change tab order and could care less about previews.

I wonder why it would be controversial to make tab switching in Firefox behave like window or tab switching in all other programs/OS's.
(Assignee)

Comment 3

3 years ago
(In reply to Carlin Scott from comment #2)
> It gets enabled if you enable browser.ctrlTab.previews in about:config. I
> feel like that is a bug because I only want to change tab order and could
> care less about previews.

If you press Ctrl+Tab quickly, you'll get to the previous tab without previews. The UI is however crucial for switching to an older tab (as with OS-level application switching, e.g. Alt+Tab). There's no sane way around that.

> I wonder why it would be controversial to make tab switching in Firefox
> behave like window or tab switching in all other programs/OS's.

I said why in the first sentence. It doesn't matter for this bug, though, because even if we enable it by default, we should expose the preference so users can opt out.
Comment hidden (off-topic)
(Assignee)

Comment 5

3 years ago
(In reply to Carlin Scott from comment #4)
> That's all fine but that means the setting is named after the feature that
> makes the "real" feature easier to use. I'm no usability expert but that
> sure seems confusing.

It's just the name of the hidden pref, so usability isn't a concern. This bug is about exposing a visible pref regardless of how it's called under the hood.

> > > I wonder why it would be controversial to make tab switching in Firefox
> > > behave like window or tab switching in all other programs/OS's.
> > 
> > I said why in the first sentence. It doesn't matter for this bug, though,
> > because even if we enable it by default, we should expose the preference so
> > users can opt out.
> I don't find that explanation of the reasoning sufficient.

This is off-topic for this bug.

> I think this point is important for this bug because it should help convince
> the team to go ahead with the change.

This is not the place for that. Please consider posting to the firefox-dev mailing list (https://wiki.mozilla.org/Firefox/firefox-dev).
(Assignee)

Updated

3 years ago
Attachment #8542990 - Flags: ui-review?(philipp)
Attachment #8542990 - Flags: ui-review?(ux-review)
Attachment #8542990 - Flags: ui-review?(philipp)
Attachment #8542990 - Flags: ui-review+

Comment 6

11 months ago
@Jack & Tina,
Please have a look. How do you think about this preference, thanks.
Flags: needinfo?(thsieh)
Flags: needinfo?(jalin)

Comment 7

11 months ago
Hi - Chiming in here - but not sure I understand the bug fully.  To me, it seems like this falls under the category of "Pro Tip" vs. a setting.  I think it's valuable to expose this but maybe not that important to allow a user to disable this? Is there anything a user gains by disabling the keyboard shortcut?  For example, they won't see the most recently opened tab, but will see the tabs in some other order? FWIW, I am happy to create messaging around pro tips and don't think it's necessary to disable something that every browser does (similar to operating systems and alt+tab or cmd + tab) unless there is something I gain from it.
Dao, is anything else needed to fix this? Do we still want to expose this about:config flag to preferences?

(Please ni Tina/Jack if you are looking for UX consultation -- they are assigned to work on a re-design of the in-content preferences page)
Flags: needinfo?(thsieh)
Flags: needinfo?(jalin)
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 9

11 months ago
Apparently this got ui-review+ last December. I missed that. I'm gonna rebase the patch and request code review.
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 10

11 months ago
Created attachment 8775099 [details] [diff] [review]
patch
Attachment #8542989 - Attachment is obsolete: true
Attachment #8775099 - Flags: review?(mdeboer)
Comment on attachment 8775099 [details] [diff] [review]
patch

Review of attachment 8775099 [details] [diff] [review]:
-----------------------------------------------------------------

I totally dig this feature! The wording of the checkbox label leaves a bit to be desired, I think. Fodder for later?

::: browser/locales/en-US/chrome/browser/preferences/tabs.dtd
@@ +2,5 @@
>     - License, v. 2.0. If a copy of the MPL was not distributed with this
>     - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
>  
> +<!ENTITY ctrlTabRecentlyUsedOrder.label       "Ctrl+Tab cycles through tabs in recently used order">
> +<!ENTITY ctrlTabRecentlyUsedOrder.accesskey   "T">

ITYM s/T/t/, because otherwise the whole accesskey swapparoo below and in main.dtd is confusing...
Attachment #8775099 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 12

11 months ago
(In reply to Mike de Boer [:mikedeboer] from comment #11)
> Comment on attachment 8775099 [details] [diff] [review]
> patch
> 
> Review of attachment 8775099 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I totally dig this feature! The wording of the checkbox label leaves a bit
> to be desired, I think. Fodder for later?

Sure. I think I originally stole this string from Opera.

> ::: browser/locales/en-US/chrome/browser/preferences/tabs.dtd
> @@ +2,5 @@
> >     - License, v. 2.0. If a copy of the MPL was not distributed with this
> >     - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
> >  
> > +<!ENTITY ctrlTabRecentlyUsedOrder.label       "Ctrl+Tab cycles through tabs in recently used order">
> > +<!ENTITY ctrlTabRecentlyUsedOrder.accesskey   "T">
> 
> ITYM s/T/t/, because otherwise the whole accesskey swapparoo below and in
> main.dtd is confusing...

No, we want the uppercase T to be underlined rather than the lowercase one, so we need to use "T" here.
(In reply to Dão Gottwald [:dao] from comment #12)
> No, we want the uppercase T to be underlined rather than the lowercase one,
> so we need to use "T" here.

Ahhh (/me facepalms) that's how it worked. Thanks for the explanation.

Comment 14

11 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/739a8707a3e2
Expose preference for having Ctrl+Tab cycle through tabs in recently used order. ui-r=phlsa r=mikedeboer
(Assignee)

Comment 15

11 months ago
Release Note Request (optional, but appreciated)
[Why is this notable]: We've had this feature behind a hidden pref for many years and anecdotal evidence suggests that many power users who found out about it like it
[Suggested wording]: New preference for allowing Ctrl+Tab to cycle through tabs in recently used order
[Links (documentation, blog post, etc)]: no documentation yet, but we should add that
relnote-firefox: --- → ?
Keywords: user-doc-needed
Ad.: We should _seriously_ consider having this feature ON by default. The current ctrl-tab behavior is so useless, compared to this, and is not a joy to use. This is in fact a joy.

Comment 17

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/739a8707a3e2
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50

Comment 18

11 months ago
Added to Fx50 (Aurora) release notes.
relnote-firefox: ? → 50+
Setting the qe-verify+ flag so we get some QA work here, since this is a new setting that we're making available to the users.
Flags: qe-verify+

Comment 20

9 months ago
I was able to reproduce previous behavior on an older Nightly build 41.0a1 (2015-06-05), on Windows 10 Pro x64

The fix was verified on Firefox Beta 50.0b4, across platforms: Windows 10 Pro x64, Ubuntu 16.04 LTS x64 and Mac OS Yosemite 10.10.4
Thank you, Carmen!
Status: RESOLVED → VERIFIED
status-firefox50: fixed → verified
Flags: qe-verify+

Updated

5 months ago
Depends on: 1335108
You need to log in before you can comment on or make changes to this bug.