Closed Bug 13352 Opened 21 years ago Closed 20 years ago

[BLOCKER][PP] Document Done no longer displayed for blank page

Categories

(SeaMonkey :: General, defect, P1, blocker)

defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: pawyskoczka, Assigned: warrensomebody)

References

Details

(Whiteboard: [Perf])

Overview Description:
In our performance testing the blank page is used as a default when obtaining
results for our launch and relaunch tests. As of todays build on all plaforms
the Document Done message is no longer being displayed at the bottom of the
browser. That makes it difficult to determine when the page has completely
loaded.

Steps to Reproduce:
1)Install the browser and make sure the nav preference is set to blank page
2)Launch the browser and wait for the page to be displayed
3)The blank page is displayed but the Document Done message is not displayed

Actual Results:
Document Done message is not displayed

Expected Results:
Document Done message is displayed


Build Date & Platform Bug Found:
9/8/99 -  All plaforms

Additional Builds and Platforms Tested On:
Windows 95, MacOs 8.6, Linux 6.0

Additional Information:
None
Severity: critical → blocker
QA Contact: leger → paw
Updating QA Contact...marking as a Blocker.  Need fixed ASAP please.
Assignee: don → radha
OS: Windows 95 → All
Priority: P3 → P1
Hardware: PC → All
Summary: Document Done no longer displayed for blank page → [BLOCKER] Document Done no longer displayed for blank page
Target Milestone: M11
Radha, is this our bug?
Status: NEW → ASSIGNED
After the first page is done loading, do you see "Document Done" messages for
subsequent loads?
I got the windows build made at 1:58 pm today from mozilla.org and tried it out.
I do see Document Done messages at the bottom as well as on the console. Can
someone show me what they are seeing or try out hte latest build.
Browser AppCore is not receiving OnEndDocumentLoad() notifications from necko
for about:blank. The "Document Done" message gets printed from
nsBrowserBrowserAppCore::OnEndDocumentLoad(). Necko has to send these in. cc'ing
warren.
Assignee: radha → rpotts
Status: ASSIGNED → NEW
I suspect that the input stream channel that about:blank uses isn't getting
inserted into the load group, and consequently the notification isn't given
when it's being removed.

I'm going to reassign this to Rick Potts (in case I don't get to it).
Ever since my last round of nsLoadGroup changes the about protocol handler
stream never got added to the LoadGroup...

This didn't seem to cause any problems at the time.  Could something else have
changed that now makes this a problem?  I don't understand what's going on
here...
Assignee: rpotts → warren
I'm kicking this one back to warren since he has some changes that should fix
this problem...
Whiteboard: [Perf]
Putting on [Perf] radar.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Should be fixed now.
Blocks: 11349
Status: RESOLVED → VERIFIED
Verified on Windows, Mac and Linux with the 9/16 build.
Status: VERIFIED → REOPENED
This is broken in today's build (9/22) on all platfoms.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
This problem is in the commerical builds with the new UI and the document done
message is not displayed when loading any page.
Target Milestone: M11 → M10
putting on my m10 radar.
So it this problem *only* in the commercial builds?  Because I'm not seeing it
in the mozilla apprunner...
The UI for the commercial build is different from the Mozilla build.
Target Milestone: M10 → M14
If this is a commercial-build-only problem, I don't see how it's a QA blocker.
I'm moving this to m14 unless someone thinks otherwise.
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
This is no longer an issue.
Status: RESOLVED → REOPENED
I am reopening this bug because as of the 10/28/99 build the "document done" message is longer displayed in the console and
therefore we cannot run our performance tests.
Summary: [BLOCKER] Document Done no longer displayed for blank page → [BLOCKER][PP] Document Done no longer displayed for blank page
This is a windows related problem only.  Linux is ok and we don't use document done on the mac.  This is only a blocker for
performance not for the product in general.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen of this bug.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Now working in build 1999-11-02-09-M11.
Status: RESOLVED → VERIFIED
Verified in build 1999-11-02-09-M11.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.