Closed Bug 1335262 Opened 3 years ago Closed 3 years ago

Add max-message-size support for data-channels

Categories

(Core :: WebRTC: Signaling, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox54 --- wontfix
firefox55 --- fixed
Blocking Flags:

People

(Reporter: drno, Assigned: drno)

References

Details

Attachments

(1 file)

Bug 1160558 added support for sctp-sdp-21 and adds support for parsing the new SDP attribute 'a=max-message-size'.
But the value is not taken from the SDP and handed to the SCTP stack. And we are also not emitting max-message-size (since it's optional).
backlog: --- → webrtc/webaudio+
Rank: 25
Assignee: nobody → drno
For the record the plan here is to start emitting a=max-message-size even though we are still offering the old style data channel format.
And then we use absence of the max-message-size and if streams is 256 (assuming Chrome always used 1024 like Chrome 58 does today) that we are connected to an old Firefox version which does not support EOR (see bug 979417). Note: this logic is not part of this patch here (so far).

I checked that with the presence of a=max-message-size we can still establish data channels with Chrome.
See Also: → 979417
Comment on attachment 8873313 [details]
Bug 1335262: read and emit datachannel max-message-size.

https://reviewboard.mozilla.org/r/144770/#review148908

::: netwerk/sctp/datachannel/DataChannelProtocol.h:21
(Diff revision 1)
>  #error "Unsupported compiler"
>  #endif
>  
> -// Duplicated in fsm.def
> -#define WEBRTC_DATACHANNEL_STREAMS_DEFAULT 256
> +#define WEBRTC_DATACHANNEL_STREAMS_DEFAULT          256
> +#define WEBRTC_DATACHANNEL_PORT_DEFAULT             5000
> +#define WEBRTC_DATACHANELL_MAX_MESSAGE_SIZE_DEFAULT 64000

draft-ietf-mmusic-sctp-sdp-26 says the default is 64K.  While "K" is indeterminate in definition here, I had assumed it was 65536, not 64000.

Suggest checking with Crister/etc about clarifying that.
Attachment #8873313 - Flags: review?(rjesup) → review+
Comment on attachment 8873313 [details]
Bug 1335262: read and emit datachannel max-message-size.

https://reviewboard.mozilla.org/r/144770/#review148908

> draft-ietf-mmusic-sctp-sdp-26 says the default is 64K.  While "K" is indeterminate in definition here, I had assumed it was 65536, not 64000.
> 
> Suggest checking with Crister/etc about clarifying that.

Pinged Christer.
And changed the code to 65536 as I personally don't care.
Christer confirmed that 65535 is/was the intended value (and forwarded the request to update the draft to WG and AD - because it pretty late in draft process).
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/9fa721e390ad
read and emit datachannel max-message-size. r=jesup
https://hg.mozilla.org/mozilla-central/rev/9fa721e390ad
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
54 RC build is released. Mark 54 won't fix.
You need to log in before you can comment on or make changes to this bug.