Closed Bug 1335359 Opened 3 years ago Closed 7 months ago

Crash (in Fx52b1 and earlier) or drawing is black on Google docs with gfx.canvas.azure.backends=cairo

Categories

(Core :: Canvas: 2D, defect, P5, critical)

52 Branch
All
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
platform-rel --- -
firefox51 --- affected
firefox52 --- affected
firefox53 --- ?
firefox54 --- ?

People

(Reporter: yfdyh000, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted][platform-rel-Google][platform-rel-GoogleSuite][platform-rel-GoogleDocs])

Crash Data

Attachments

(1 file)

STR:
1. Change the gfx.canvas.azure.backends to "cairo", (or "direct2d1.1,cairo" with gfx.direct2d.disabled to true), then restart the browser.
2. Open the https://docs.google.com/spreadsheets/d/194EX47CBSwTzi1cpFUi19VQtWeygDCEwr3xMljnSMug/edit.


Actual results:
Browser crashes in non-e10s; the tab crashes in e10s. e.g. bp-dc0ded44-6d28-46ab-93b3-0d0642170131

In Fx52b2 (bug 1319668 has landed), the editable area is black, see the screenshot. It remains black when other cells are selected, but flush to normal if the viewport resize, e.g. resize the window, or switch the bookmarks toolbar.
In order to reproduce it, about:support - Features - Compositing must be Basic, but I'm not sure which prefs are needed to affect it in a new profile.
We'll take patches that fix this, but given that it isn't a supported configuration anymore, we're not likely to spend much time looking for the fix.
Priority: -- → P5
Whiteboard: [gfx-noted]
Duplicate of this bug: 1339762
The user from the duplicate has this crashy configuration too with Google Sheets:

Graphics
Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	none
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding	No; Hardware video decoding disabled or blacklisted
Audio Backend	wasapi
DirectWrite	false (6.1.7601.17789)
GPU #1
Active	Yes
Description	Intel(R) HD Graphics 4000
Vendor ID	0x8086
Device ID	0x0162
Driver Version	9.17.10.2828
Driver Date	7-31-2012
Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Subsys ID	1790103c
RAM	Unknown
Diagnostics
ClearType Parameters	Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
AzureCanvasAccelerated	0
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	skia
ClearType Parameters	Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
Decision Log
D3D9_COMPOSITING	
disabled by default: Disabled by default
DIRECT2D	
unavailable by runtime: Failed to acquire a Direct2D 1.1 factory
I've temporarily un-duplicated the bug mentioned in comment 4, as it's happening in 51, where Cairo is the default.  Just because it's supported vs. unsupported configuration.
One of the first clues that something is wrong: DrawTargetCairo context in error state: cairo_restore() without matching cairo_save()(2), followed by: Invalid target in gfxContext::CreatePreservingTransformOrNull
(In reply to Milan Sreckovic [:milan] from comment #6)
> One of the first clues that something is wrong: DrawTargetCairo context in
> error state: cairo_restore() without matching cairo_save()(2), followed by:
> Invalid target in gfxContext::CreatePreservingTransformOrNull

Seemingly from DrawTargetCairo::FillRect
See Also: → 1339762
The crash report from comment 0 is in Firefox 51, and I expect fixed by the patch on bug 1319668.  I see a couple of crashes in the first 52 beta, but they seem to go away as the bug 1319668 landed.

Are there any crashes we know of in 52 or higher?  Otherwise, we should just mark this as a duplicate of bug 1319668.
platform-rel: --- → ?
Whiteboard: [gfx-noted] → [gfx-noted][platform-rel-Google][platform-rel-GoogleSuite][platform-rel-GoogleDocs]
platform-rel: ? → -
Severity: major → critical
Keywords: crash
In the last 3 months, only a dozen 60.x crashes that are not android. And all 61.x 62.x crashes are android

https://crash-stats.mozilla.com/signature/?signature=gfxContext%3A%3ACurrentState&date=%3E%3D2018-06-05T00%3A27%3A09.000Z&date=%3C2018-09-05T00%3A27%3A09.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-version&_sort=build_id&_sort=-date&page=1

bp-23fc5a72-7cd4-4c9c-9c42-0f6f90180904 	2018-09-04 16:34:24 	FennecAndroid 	62.0 	20180828135931 	Android
bp-26c5c83c-d692-47a9-a222-f7b080180821 	2018-08-21 08:50:34 	FennecAndroid 	61.0.2 	20180807170231 	Android
bp-2a869401-f268-4cce-a98f-1a0a80180810 	2018-08-10 22:03:58 	FennecAndroid 	61.0 	20180621125625 	Android
bp-5c878026-f698-4d5f-b435-4b40c0180810 	2018-08-10 22:03:36 	FennecAndroid 	61.0 	20180621125625 	Android
bp-9d536d5d-2b6a-40b3-b100-507440180716 	2018-07-16 15:10:03 	FennecAndroid 	61.0 	20180621125625 	Android
bp-8f466f92-98b3-42bf-9b61-bdcc50180716 	2018-07-16 15:09:48 	FennecAndroid 	61.0 	20180621125625 	Android
bp-a48cb054-6367-4da9-905b-b58410180716 	2018-07-16 15:09:32 	FennecAndroid 	61.0 	20180621125625 	Android
bp-5f00dd4c-6d90-4200-a4d4-73fe60180703 	2018-07-03 12:08:04 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-a8106eea-5676-451b-886a-8d3310180702 	2018-07-02 08:09:38 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-d06d0708-4c4a-4876-bce5-bac4a0180630 	2018-06-30 16:04:14 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-83f1247a-9ed6-45cc-a7b4-c78990180629 	2018-06-29 11:57:30 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-04778d1e-6ca5-48d1-8dae-3a8c20180625 	2018-06-25 10:39:29 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-2e0dd3e8-85cd-4b0c-841f-1f50f0180619 	2018-06-19 16:56:42 	Firefox 	60.0.2 	20180605171542 	Windows NT
bp-7a0d1fb1-3def-4be2-b24d-45c300180618 	2018-06-18 21:23:42 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-d3aff2ee-8920-4058-abf6-a941b0180613 	2018-06-13 17:55:50 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-ec0fc2c5-2c7c-4738-9c38-5274d0180613 	2018-06-13 17:55:30 	FennecAndroid 	60.0.2 	20180605171542 	Android
bp-e53f6504-608a-4e4f-8d75-97fac0180609 	2018-06-09 19:01:33 	Firefox 	60.0.2 	20180605171542 	Windows NT
bp-1c1abfdc-2dd1-404d-9fea-d67ae0180607 	2018-06-07 11:17:52 	FennecAndroid 	60.0.1 	20180515214401 	Android
bp-99ba93a9-6d6e-453c-a4f7-e756d0180606 	2018-06-06 17:36:48 	Firefox 	60.0.1 	20180516032328 	Windows NT

Bug 1559810 - disallow Cairo as content/canvas backend. r=jrmuizel

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Depends on: 1559810
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.