Closed Bug 13354 Opened 20 years ago Closed 19 years ago

Content ignored because of unclosed <P> inside <IFRAME>

Categories

(Core :: HTML: Parser, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 22842

People

(Reporter: Bienvenu, Assigned: rickg)

References

()

Details

(Keywords: testcase, Whiteboard: [nsbeta3-][TESTCASE])

Attachments

(1 file)

This web page doesn't load with the 5.0 browser, except for the ad. I tried it
with 4.6 and it loaded fine.

here's what got dumped to the console:

Recieving ... datais=CTFTW; path=/; domain=.datais.com

Recieving ... datref=(null)
freq52=1|936818398; expires=Thursday, 9-Sep-1999 16:19:58 GMT
ryanstev_1=52-1; path=/; domain=.datais.com
dataisUN=a1d5nm4ld9; expires=Thursday, 7-Sep-2000 15:19:58 GMT; path=/

Recieving ... datref=(null)
ryanstev_1=48-2; path=/; domain=.datais.com
Going to reload
Error loading URL http://www.kaitaia.com/top.htm
Document: Done (0.078 secs)
Error loading URL http://leader.linkexchange.com/1/X1123330/clickto_X1084922?262
,47
Document: Done (3.531 secs)
The console messages may be a red herring - the page failed to load with no
status messages the second time I tried.
Assignee: don → rickg
Component: Browser-General → Parser
Summary: page doesn't load (except for ad, thanks a lot!) → Content ignored because of unclosed <P> inside <IFRAME>
Whiteboard: [TESTCASE]
There is an unclosed <P> inside the <IFRAME> causing the rest of the
page to be considered as <IFRAME> content and thus (correctly) ignored.
However the 4.x browsers seems to do the right thing and close the <P>
upon seeing </IFRAME>.
Assignee: rickg → harishd
Status: NEW → ASSIGNED
Target Milestone: M14
QA Contact: leger → janc
Resetting QA contact from leger.
Target Milestone: M13 → M14
Priority: P3 → P2
Target Milestone: M14 → M15
Harish -- the test case seems to show that the document is coming in well
formed. Then when the source for the iframe comes in the document gets
constructed wrong. This is likely a sink problem.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Moving to M16.
Target Milestone: M15 → M16
Not a beta blocker. Moving to M17
Target Milestone: M16 → M17
Marking it for future.
Target Milestone: M17 → Future
This is a serious error!!! The markup snippet is valid -- we should NOT BE
breaking on this!!

We need to fix this to support HTML4. Nominating nsbeta3. This is more important
to fix than most compat issues...
Blocks: html4.01
Keywords: correctness, nsbeta3
Keywords: nsbeta3
Removed nsbeta3 nomination from futured bugs.
Should not remove nsbeta3 nomination. Thanks to dbaron and ekrock for the heads
up. Re-adding the nomination and marking nsbeta3-.
Keywords: nsbeta3
Whiteboard: [TESTCASE] → [nsbeta3-][TESTCASE]
This is very bad! Fortunately, it's a dup of bug 22842, which is fixed in my 
tree.
Assignee: harishd → rickg
Status: ASSIGNED → NEW
Target Milestone: Future → M18

*** This bug has been marked as a duplicate of 22842 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Duplicate which is resolved anyway. Marking as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.