Closed Bug 1335710 Opened 3 years ago Closed 3 years ago

Change with C++17 will cause a change in mozilla::BitwiseCast

Categories

(Core :: MFBT, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1320656
Tracking Status
firefox54 --- affected

People

(Reporter: Sylvestre, Unassigned)

References

Details

With gcc 7.0, the following warning is triggered:

 9:58.47 In file included from /root/firefox-gcc-last/js/src/jstypes.h:25:0,
 9:58.47                  from /root/firefox-gcc-last/obj-x86_64-pc-linux-gnu/dist/include/js/CallNonGenericMethod.h:10,
 9:58.47                  from /root/firefox-gcc-last/js/src/NamespaceImports.h:15,
 9:58.47                  from /root/firefox-gcc-last/js/src/jit/CacheIR.h:12,
 9:58.47                  from /root/firefox-gcc-last/js/src/jit/CacheIRCompiler.h:10,
 9:58.47                  from /root/firefox-gcc-last/js/src/jit/CacheIRCompiler.cpp:7,
 9:58.47                  from /root/firefox-gcc-last/obj-x86_64-pc-linux-gnu/js/src/Unified_cpp_js_src11.cpp:2:
 9:58.47 /root/firefox-gcc-last/obj-x86_64-pc-linux-gnu/dist/include/mozilla/Casting.h:42:1: error: mangled name for 'void mozilla::BitwiseCast(From, To*) [with To = void*; From = float (*)(float) throw ()]' will change in C++17 because the exception specification is part of a function type [-Werror=c++1z-compat]
 9:58.47  BitwiseCast(const From aFrom, To* aResult)
 9:58.47  ^~~~~~~~~~~
 9:58.49 libgfx_thebes.a.desc
 9:58.52 /root/firefox-gcc-last/obj-x86_64-pc-linux-gnu/dist/include/mozilla/Casting.h:57:1: error: mangled name for 'To mozilla::BitwiseCast(From) [with To = void*; From = float (*)(float) throw ()]' will change in C++17 because the exception specification is part of a function type [-Werror=c++1z-compat]
 9:58.52  BitwiseCast(const From aFrom)
 9:58.52  ^~~~~~~~~~~
Component: JavaScript Engine: JIT → MFBT
Is this different from Bug 1320656?
Flags: needinfo?(sledru)
Ouch, sorry, I am starting to become senile :(
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(sledru)
Resolution: --- → DUPLICATE
Duplicate of bug: 1320656
No longer blocks: 1566181
Blocks: cxx17
You need to log in before you can comment on or make changes to this bug.