Closed Bug 1336334 Opened 3 years ago Closed 11 months ago

[viewport] initial-scale=2.0 clamp to 980px on a 360px screen

Categories

(Core :: Panning and Zooming, defect, P3)

54 Branch
ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1494422
Tracking Status
firefox54 --- affected

People

(Reporter: karlcow, Unassigned)

References

()

Details

(Whiteboard: [webcompat][gfx-noted])

(change the product/component adequately if I missed something)

This issue is part of a couple of tests, I'm doing comparing Firefox Android and Chrome Android for layout differences wrt viewport values.
The tests are available at http://la-grange.net/2016/12/01/viewport/

Test 0005 - <name="viewport" content="initial-scale=2.0">
http://la-grange.net/2016/12/01/viewport/viewport-test-0005.html

Screenshots are not necessary useful here, but the values are interesting.


Firefox
    1: window.devicePixelRatio
    980 px: document.documentElement.clientWidth
    879 px: document.documentElement.clientHeight
    964 px: document.body.clientWidth
    1309 px: document.body.clientHeight
    360 px: window.screen.width
    592 px: window.screen.height
    360 px: window.innerWidth
    592 px: window.innerHeight


Chrome
    3: window.devicePixelRatio
    180 px: document.documentElement.clientWidth
    255 px: document.documentElement.clientHeight
    164 px: document.body.clientWidth
    2076 px: document.body.clientHeight
    360 px: window.screen.width
    640 px: window.screen.height
    360 px: window.innerWidth
    640 px: window.innerHeight
when initial-scale is different from 0 be for 0.5 ( Bug #1336330 ) or 2.0 (here), Firefox seems to clamp the documentElement.clientWidth to 980px.
Whiteboard: [webcompat]
The values are strange, I'm hesitating opening a separate bug for this test with an extreme small value.
http://la-grange.net/2016/12/01/viewport/viewport-test-0006.html

* Firefox
    3600px: document.documentElement.clientWidth

* Chrome
    1440px: document.documentElement.clientWidth

This time Chrome seems to clamp.
Component: Graphics, Panning and Zooming → Panning and Zooming
OS: Unspecified → Android
Priority: -- → P3
Product: Firefox for Android → Core
Hardware: Unspecified → ARM
Whiteboard: [webcompat] → [webcompat][gfx-noted]
See Also: → 1336330
This seems also to be relevant with 'extend-to-zoom'.
See Also: → 1494422
Now I am convinced this case will be fixed by 1494422.
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
See Also: 1494422
Duplicate of bug: 1494422
You need to log in before you can comment on or make changes to this bug.