Implement "extend-to-zoom" semantics in meta viewport tags

RESOLVED FIXED in Firefox 64

Status

()

enhancement
P3
normal
RESOLVED FIXED
11 months ago
20 days ago

People

(Reporter: botond, Assigned: hiro)

Tracking

(Blocks 2 bugs)

Trunk
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

()

Attachments

(2 attachments)

In https://webcompat.com/issues/18826, there is a webpage for which Firefox computes the layout viewport size based on the meta viewport tag differently from Chrome, and as a result the page is rendered differently.

The difference seems to be related to the "extend-to-zoom" semantics in the CSS Device Adaption spec (see [1]), which I believe Firefox does not implement.

[1] https://webcompat.com/issues/18826#issuecomment-423704698
Taking, I am going to fix this first.
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Duplicate of this bug: 1336330
See Also: → 1336334
Blocks: 1407582
See Also: 1336334
Duplicate of this bug: 1336334
In the previous try, I did forget to factor layoutDeviceScale into scale values, so the sites in question were correctly scaled in RDM with enabling touch and apz.allow_zooming but not on Android devices.

Here is a new try.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3a342af240a90e288a28f0bb1c17443bba994220
Moving a bunch of webcompat issue links in bug 1469747 into here.  Basically sites having 'initial-scale' but no 'width' in meta viewport will be fixed by extend-to-zoom.
Blocks: 1323062
Duplicate of this bug: 1469747
Priority: -- → P3
Attachment #9017064 - Attachment description: Bug 1494422 - Introduce exntend-to-zoom and resolve width and height using it. r=botond → Bug 1494422 - Introduce extend-to-zoom and resolve width and height using it. r=botond
Never mind about the above try.  I thought all patches have gotten r+. :)
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7172b2e62e0
Introduce extend-to-zoom and resolve width and height using it. r=botond
https://hg.mozilla.org/integration/autoland/rev/d94fc104be3b
Test cases for viewport calculation. r=botond
https://hg.mozilla.org/mozilla-central/rev/a7172b2e62e0
https://hg.mozilla.org/mozilla-central/rev/d94fc104be3b
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Blocks: 1564943
You need to log in before you can comment on or make changes to this bug.