Closed Bug 1336379 Opened 6 years ago Closed 6 years ago

Implement Statistics Panel component

Categories

(DevTools :: Netmonitor, defect, P1)

defect

Tracking

(firefox54 verified)

VERIFIED FIXED
Firefox 54
Iteration:
54.1 - Feb 6
Tracking Status
firefox54 --- verified

People

(Reporter: rickychien, Assigned: rickychien)

References

(Blocks 1 open bug)

Details

(Whiteboard: [netmonitor])

Attachments

(1 file)

Architecture reactify step for creating top level NetworkMonitor react component.

* Implement StatisticsPanel component instead of statistics-view.js
* Remove statistics-view.js
* Move whenDataAvailable mechanism to StatisticsPanel
Comment on attachment 8833290 [details]
Bug 1336379 - Implement StatisticsPanel

https://reviewboard.mozilla.org/r/109546/#review110612

I like it, just couple of comments.

R+ assuming you resolve my comments and try is green.

Thanks!
Honza

::: devtools/client/netmonitor/components/statistics-panel.js:33
(Diff revision 1)
> +const BACK_BUTTON = L10N.getStr("netmonitor.backButton");
> +const CHARTS_CACHE_ENABLED = L10N.getStr("charts.cacheEnabled");
> +const CHARTS_CACHE_DISABLED = L10N.getStr("charts.cacheDisabled");
> +
> +/*
> + * Statistics panel componennt

typo: componennt -> component

::: devtools/client/netmonitor/netmonitor-view.js
(Diff revision 1)
>    },
>  
> -  /**
> -   * Gets the current mode for this tool.
> -   * @return string (e.g, "network-inspector-view" or "network-statistics-view")
> -   */

Why did you remove the comments?

::: devtools/client/netmonitor/netmonitor-view.js
(Diff revision 1)
> -      clearInterval(interval);
> -      reject(new Error("Timed out while waiting for data"));
> -    }, WDA_DEFAULT_GIVE_UP_TIMEOUT);
> -  });
> -}
> -

Nice simplification! (code removal)
Attachment #8833290 - Flags: review?(odvarko) → review+
Comment on attachment 8833290 [details]
Bug 1336379 - Implement StatisticsPanel

https://reviewboard.mozilla.org/r/109546/#review110612

> Why did you remove the comments?

Oops! It was a mistake when splitting the commit. But I'd like to drop this issue because this part (netmonitor-view.js) will be removed soon.
Iteration: --- → 54.1 - Feb 6
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [netmonitor][triage] → [netmonitor]
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f0ca34823cf7
Implement StatisticsPanel r=Honza
https://hg.mozilla.org/mozilla-central/rev/f0ca34823cf7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Flags: qe-verify? → qe-verify+
QA Contact: ciprian.georgiu
I have performed tests around Statistics Panel on latest Nightly 54.0a1 (2017-02-09), and I can confirm that everything is working as expected across platforms: Windows 10 x64, Ubuntu 16.04 LTS and Mac OS X 10.11.6.

Marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1427149
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.