Closed Bug 1336507 Opened 3 years ago Closed 3 years ago

Local relay transport is not properly displayed on about:webrtc

Categories

(Core :: WebRTC: Signaling, defect, P2)

48 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox53 --- fixed
firefox54 --- fixed
Blocking Flags:

People

(Reporter: bwc, Assigned: bwc)

References

Details

Attachments

(4 files)

It seems that about:webrtc is no longer displaying the "-udp" or "-tcp" suffix for local relay candidates.

Also, while we're at it, we should add a "-tls" suffix.
It should be noted that this hampers manual testing for bug 1056934.
Rank: 25
Priority: -- → P2
backlog: --- → webrtc/webaudio+
Comment on attachment 8833533 [details]
Bug 1336507 - Part 2: Move some TLS related stuff from |connect| to |create|, so it is better reflected in candidate labels/codeword.

https://reviewboard.mozilla.org/r/109758/#review110814
Attachment #8833533 - Flags: review?(drno) → review+
Comment on attachment 8833534 [details]
Bug 1336507 - Part 3: Make sure mozLocalTransport is set to "tls" where appropriate.

https://reviewboard.mozilla.org/r/109760/#review110816
Attachment #8833534 - Flags: review?(drno) → review+
Comment on attachment 8833535 [details]
Bug 1336507 - Part 4: Stop using a magic constant here.

https://reviewboard.mozilla.org/r/109762/#review110818
Attachment #8833535 - Flags: review?(drno) → review+
Comment on attachment 8833532 [details]
Bug 1336507 - Part 1: Fix about:webrtc display of local relay transport.

https://reviewboard.mozilla.org/r/109756/#review111320
Attachment #8833532 - Flags: review?(jib) → review+
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd81e72532b3
Part 1: Fix about:webrtc display of local relay transport. r=jib
https://hg.mozilla.org/integration/autoland/rev/73fb6dab1ea9
Part 2: Move some TLS related stuff from |connect| to |create|, so it is better reflected in candidate labels/codeword. r=drno
https://hg.mozilla.org/integration/autoland/rev/31bf2f8302b0
Part 3: Make sure mozLocalTransport is set to "tls" where appropriate. r=drno
https://hg.mozilla.org/integration/autoland/rev/f3da0505833f
Part 4: Stop using a magic constant here. r=drno
Depends on: 1340676
Blocks: 1340734
No longer blocks: 1340734
Depends on: 1340734
Is this ready to uplift to Fx 53?
Flags: needinfo?(docfaraday)
Comment on attachment 8833535 [details]
Bug 1336507 - Part 4: Stop using a magic constant here.

Approval Request Comment for all patches


[Feature/Bug causing the regression]:

   Relay transport display on about:webrtc was broken by bug 1322503. Display of tls transport on about:webrtc was not implemented until this bug.

[User impact if declined]:

   Manual testing of TURN TLS and draft-ietf-rtcweb-ip-handling will be more difficult without this fix.

[Is this code covered by automated tests?]:

   No.

[Has the fix been verified in Nightly?]:

   Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 

   No.

[List of other uplifts needed for the feature/fix]:

   Bug 1340734.

[Is the change risky?]:

   Not very.

[Why is the change risky/not risky?]:

   This isn't a huge change, and a fair bit of it is just code cleanup.

[String changes made/needed]:

   None.
Flags: needinfo?(docfaraday)
Attachment #8833535 - Flags: approval-mozilla-aurora?
Hi :bwc,
Just to be sure, you want to uplift all parts, right?
Flags: needinfo?(docfaraday)
Yes, as well as the dependencies.
Flags: needinfo?(docfaraday)
Comment on attachment 8833535 [details]
Bug 1336507 - Part 4: Stop using a magic constant here.

Fix a local relay transport display issue on about:webrtc. Aurora54+.
Attachment #8833535 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8833535 [details]
Bug 1336507 - Part 4: Stop using a magic constant here.

Just noticed that these changes have been in 54. We don't need to uplift these changes to Aurora54 again.
Attachment #8833535 - Flags: approval-mozilla-aurora+ → approval-mozilla-aurora-
Comment on attachment 8833535 [details]
Bug 1336507 - Part 4: Stop using a magic constant here.

Gah, I had intended to ask for uplift to 53.
Attachment #8833535 - Flags: approval-mozilla-beta?
Comment on attachment 8833532 [details]
Bug 1336507 - Part 1: Fix about:webrtc display of local relay transport.

Support for TLS and WebRTC, please uplift all 4 patches here to beta, after uplifting work from bug 1340734.
Attachment #8833532 - Flags: approval-mozilla-beta+
Alexandru, if you are still testing this feature for 53, this work should land for beta 3.
Flags: needinfo?(alexandru.simonca)
Attachment #8833535 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Sure thing! I'll get on it as soon as beta 3 is out.
Setting qe-verify- based on Byron's assessment on manual testing needs (see Comment 17).
Flags: qe-verify-
Flags: needinfo?(alexandru.simonca)
You need to log in before you can comment on or make changes to this bug.